VirtualBox

Ticket #8133 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

VM additions display error and cant connect via RDP

Reported by: gnordli Owned by:
Priority: major Component: guest additions
Version: VirtualBox 4.0.2 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

I am having problems with the vm additions after I upgrade to 4.0.2. The VM works ok running older 3.x series additions.

It affects both Windows (XP) and Linux (Ubuntu Lucid) guests.

If I run a GUI on the VM, I can see it boot properly but the display is very, very small (something like 20x20) and trying to expand the window doesn't work.

In headless mode, I can't connect via RDP.

In the log I see a bunch of these error messages.

00:00:31.617 ERROR [COM]: aRC=VBOX_E_IPRT_ERROR (0x80bb0005) aIID={09eed313-cd56-4d06-bd56-fac0f716b5dd} aComponent={Display} aText={Could not take a screenshot (VERR_NOT_SUPPORTED)}, preserve=false 00:00:31.658 ERROR [COM]: aRC=VBOX_E_IPRT_ERROR (0x80bb0005) aIID={09eed313-cd56-4d06-bd56-fac0f716b5dd} aComponent={Display} aText={Could not take a screenshot (VERR_NOT_SUPPORTED)}, preserve=false

So my guess it is something with the video driver.

Attachments

vbox_error.log Download (56.3 KB) - added by gnordli 3 years ago.
vboxlog_startup_gui.txt Download (44.9 KB) - added by gnordli 3 years ago.
vboxlog_rdp_disabled.txt Download (43.4 KB) - added by gnordli 3 years ago.
RDP is disabled and the VM boots properly

Change History

Changed 3 years ago by gnordli

comment:1 Changed 3 years ago by sunlover

The attached log shows that after starting up the guest has changed the resolution to 1908x1042. Then a RDP client has successfully connected and requested to set the resolution to 200x200.

Also the log shows that the VM has been started from a saved state.

So it does show that a RDP connect fails or that the VM display is small.

Could you attach a log for booting the VM from power off state?

comment:2 Changed 3 years ago by gnordli

I missed the 200x200 video mode hint.

This seems to be intermittent, sometimes the machine resumes from suspend without seeing that 200x200 msg in the log file.

As well, I tried "VBoxManage controlvm S003-V521 setvideomodehint 1024 768 16" to see if it would adjust it:

01:30:33.708 VMMDev::SetVideoModeHint: got a video mode hint (1024x768x16) at 0 01:30:33.719 Guest Log: VBoxDisp[0]: VBVA enabled 01:30:33.719 Display::handleDisplayResize(): uScreenId = 0, pvVRAM=00007f9344694000 w=1024 h=768 bpp=16 cbLine=0x800, flags=0x1 01:30:33.938 VMMDev::SetVideoModeHint: got a video mode hint (200x200x0) at 0 01:30:33.952 Guest Log: VBoxDisp[0]: VBVA enabled

BTW, I tried to "reset" the machine, but it wouldn't allow me to. I needed to actually kill the process first.

I started the vm using the GUI, and I tried to resize the window and it kept going back to the 200x200 setting.

Changed 3 years ago by gnordli

comment:3 Changed 3 years ago by gnordli

Maybe it has something to do with the RDP server. I disabled RDP access and the VM booted correct. I attached the log vboxlog_rdp_disabled.txt.

Changed 3 years ago by gnordli

RDP is disabled and the VM boots properly

comment:4 Changed 3 years ago by gnordli

I enabled RDP again and it booted fine. So definitely the issue is intermittent. Maybe you can give me some guidance on how you would like me to test.

comment:5 Changed 3 years ago by sunlover

  • Priority changed from critical to major

Thanks for the logs and for testing.

It would help to find out, which conditions lead to the problem. Theoretically the RDP server can not affect the VM window resizing.

comment:6 Changed 3 years ago by gnordli

I am not sure what has happened here, but over the past couple of days I have not seen another freeze; even with the 4.0.2 additions.

You can close this and if it happens again I will reopen.

thanks,

Geoff

comment:7 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use