VirtualBox

Ticket #8116 (closed defect: obsolete)

Opened 3 years ago

Last modified 3 months ago

3d-accelleration does not work in debian-squeeze-guests

Reported by: aglaeser Owned by:
Priority: minor Component: guest additions
Version: VirtualBox 4.0.0 Keywords: 3d-accelleration
Cc: glaeser@… Guest type: Linux
Host type: Windows

Description (last modified by frank) (diff)

I am running Debian Squeeze beta on VirtualBox Version 4.0 on a Windows XP host and found that the 3d-accelleration feature does not work, when using the guest-additions, which belong to the distribution. There was a message that said, that the guest-additions for the current version 4 are required for that. A web-search for the current guest additions was not successful. Neither are there any linux packages provided, nor the source-code. My skills are not sufficient to download the whole VirtualBox-Sourcecode and compile the required guest-additions only.

Change History

comment:1 Changed 3 years ago by aglaeser

Here is something, I forgot to mention: I tried to uninstall the three virtualbox-guest -packages using aptitude and to install new ones, but choosing ´install guest additions...´ from the ´Devices´-Menu did not trigger any reaction. -maybe the quoted terms are not literally correct, because I am using a german version and this is how I would re-translate these words into english-. The bahaviour of VirtualBox 4.0.2 does not differ in this point either.

comment:2 Changed 3 years ago by aglaeser

Update: When I reinstalled the packages virtualbox-ose-guest-dkms and virtualbox-guest-utils I found a CD-drive on the desktop, named ´VBOXADDITIONS_4.0.2_69518´, mounted it and uninstalled the virtualbox-ose-guest-*-packages and then said: #cd /media/cdrom0 #sh VBoxLinuxAdditions.run the message remained, which said, that there was already an older version of the guest-additions installed, which should be removed first. Possibly purging the packages instead of just removing them would have changed that. Upon installation the guest-system was restarted and hardware-accelleration worked. So the issue can be regarded as solved now, although it could be made clearer for the users, that the necessary files are being downloaded, when they select ´install guest additions...´ from ´Devices´-menu.

comment:3 Changed 3 months ago by frank

  • Status changed from new to closed
  • Resolution set to obsolete
  • Description modified (diff)
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use