VirtualBox

Ticket #8110 (closed defect: fixed)

Opened 3 years ago

Last modified 2 years ago

Regression: Extpack fails to update as normal user

Reported by: Sasquatch Owned by:
Priority: critical Component: other
Version: VirtualBox 4.0.2 Keywords:
Cc: Guest type: other
Host type: Linux

Description (last modified by frank) (diff)

One cannot update, remove or install the ExtPack as normal user. The CLI gives the following error when trying with the following command:

VBoxManage extpack uninstall "Oracle VM VirtualBox Extension Pack"
0%...
Progress state: NS_ERROR_FAILURE
VBoxManage: error: Failed to uninstall "Oracle VM VirtualBox Extension Pack":
The installer failed with exit code 127: Error executing command as another
user: No authentication agent was found.

The GUI shows the same error. Same thing happens when trying to install the ExtPack. One was able to upgrade the ExtPack on 4.0.0 (when the beta ExtPack was installed for example). I had to use sudo to install the ExtPack.

Please revise 4.0.2 ASAP so the forum isn't filled with this problem.

Change History

comment:1 Changed 3 years ago by frank

When installing the extension pack there needs to be one of the following authentication applications installed:

  • kdesudo
  • gksu
  • pkexec
  • xterm + su

It sounds like either all four cases fail or one of these applications is installed but fails to executed with the above error. Note that we have to use su+sudo and the deb/rpm packages did not do this with VBox 4.0 which was a bug.

comment:2 Changed 3 years ago by frank

  • Description modified (diff)

comment:3 Changed 3 years ago by Sasquatch

Ah, that makes sense. I don't have xterm or gksu (or other 'graphical' su apps). It's odd that you don't use the current terminal emulator with su(do) when doing it from the command line. So even if you don't have such apps like I do on my computer, a server OS usually doesn't have it either. Or it's not available from a TTY (how do you access xterm from there, or gksu?). I know that pkexec is part of policykit, but even that is not installed on Ubuntu server for example. Is there anything that I can do to get more debug information? I know it worked on 4.0.0 without all these applications installed.

comment:4 Changed 3 years ago by frank

That it worked with VBox 4.0.0 was a bug. With VBox 4.0 it was possible that a normal user without root permission could start the VirtualBox GUI and install a malicious extension pack gaining root access.

Regarding the current terminal: Note that the installation is done starting from the context of VBoxSVC which does not necessarily run on a terminal.

comment:5 Changed 3 years ago by Sasquatch

Ok. I upgraded VB to 4.0.2 and it's extpack on a more 'complete' system and got gksu asking for a password. This makes the priority less severe, but it's still something to consider fixing. There might be others who don't have the above mentioned packages like me. Is it possible to throw a different error than the one I noted, something like "install or remove the extpack as root"? Chapter 1.5 doesn't mention the requirement of administrative (root) privileges either, might want to update that as well.

comment:6 Changed 3 years ago by Sasquatch

I just checked my PC installation, and it DOES have policykit installed, thus has pkexec. Anything I can do to figure out why it doesn't pick it up?

comment:7 Changed 3 years ago by Sasquatch

Read the man page of pkexec. It gives this error when authentication fails. Default on Ubuntu (and maybe more distro's), is that the root user has no password set. This probably causes this error. Catching this error and show a proper message will do for me to close this report.

comment:8 Changed 2 years ago by singh.gurjeet

This command worked for me:

sudo VBoxManage extpack install --replace .VirtualBox/Oracle_VM_VirtualBox_Extension_Pack-4.1.4.vbox-extpack

comment:9 Changed 2 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
  • Description modified (diff)

Please reopen if still relevant with VBox 4.1.10.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use