VirtualBox

Ticket #8097 (new defect)

Opened 3 years ago

Last modified 3 years ago

USB - VB freezes when Logitech camera redirected (reproduceable)

Reported by: danf84 Owned by:
Priority: critical Component: USB
Version: VirtualBox 4.0.0 Keywords: logitech webcam usb x64
Cc: Guest type: Windows
Host type: Windows

Description

This has been tested on my colleagues computer (Dell AMD with Win7 x64) and my own, Dell Vostro 1720 (Centrino, Intel DC P8600 Win7 x64).

While VM is running, redirecting USB at first attempt caused Windows not to install the VirtualBox USB driver, on second attempt VirtualBox VM and the GUI EXEs froze.

Webcam model: Logitech QuickCam 3000 - Model No: V-U0001 (latest driver, lws_bpg200.exe)

Host: Windows 7 X64 Enterprise Guest: Windows XP SP3 (updated as of 15 JAN 2011)

Thanks

Change History

comment:1 Changed 3 years ago by danf84

The tests mentioned were done with Enhanced USB Controller DISABLED.

I tried another test; enabled the Enhahnced USB Controller, the webcam actually installed in the Guest. It took a little while to initialize, and I didn't manage to get an image; it eventually crashed the Guest, but the VirtualBox main launcher was still ok (tried default Windows drivers and latest Logitech's).

To summarise,

With Enhanced USB Controller the crash occurs on access to camera (after a substantial delay). Only the VM crashes, the VirtualBox VM launcher GUI was ok and shows state "Aborted" on the crashed VM.

Without Enhanced USB Controller the crash occurs as soon as USB is initialized during Windows boot-up, just before the Windows logon UI is displayed. In this case VirtualBox crashes completely, the launcher GUI and the VM.

I never got USB 2 to work. Always had time-outs reported by the software using the devices. However, most devices I used so far weren't actually requiring or using USB 2 specifics, so they worked with Enhanced Controller turned off.

I suspect in the case of this webcam, it's probably requiring USB 2 and actually using USB 2 commands which crash VirtualBox's USB 1 proxy which doesn't know what to do with USB 2 commands (just a guess really).

I'd happily provide any help that I can if you could get the USB 2 working. I have a few devices here none of which work over USB 2, but most work with USB 1.

comment:2 Changed 3 years ago by alphazo

How do you enable the Enhanced USB controller un VirtualBox 4? I've installed virtualbox-ext-oracle and see it under Extension menu. However I no longer see any EHCI settings under USB panel. Is this normal? How can I check that EHCI is running fine?

That being said I have similar problem as yours  http://www.virtualbox.org/ticket/8184

comment:3 Changed 3 years ago by frank

The USB settings page did not change. Even if the Oracle extension pack would be inactive, the USB 2.0 (EHCI) controller setting is still there. Just enable the USB 2.0 controller for that VM and it should work. Can you confirm this? Any change with VBox 4.0.6?

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use