VirtualBox

Ticket #8088 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

VirtualBox.exe allocates 2x host RAM

Reported by: cpatulea Owned by:
Priority: major Component: other
Version: VirtualBox 4.0.0 Keywords:
Cc: Guest type: other
Host type: other

Description

VirtualBox.exe normally uses less than 100 MB of RAM on my machine. Some time after guest startup (can't repro reliably yet), it allocates 4 GB, then an extra 4 GB, causing my machine to grind to a halt while Windows scrambles to page other apps in and out of the pagefile. When I try to close the virtual machine, it gets stuck in Stopping and I have to kill the process manually.

  • Host OS: Windows XP x64
  • VirtualBox: 4.0.0 r69151 with extension pack 4.0.0 r69151
  • Guest OS: Ubuntu 10.04.1 32-bit
  • Host CPUs: 4 (i5 760)
  • Host RAM: 4 GB
  • Guest CPUs: 1
  • Guest RAM: 1 GB
  • VT-x: Enabled
  • Guest Additions: 4.0.0 r69151

Attachments:

  • Ubuntu.vbox - full vbox file of the VM in question
  • Ubuntu-2011-01-15-18-36-11.log - log file after trying to stop the machine (added a comment at the time I tried to close the machine)
  • procexp.png - Process Explorer list showing VB.exe at 8 GB
  • virtualbox_mem.png - graph of CPU, memory and I/O of VB.exe when bug has just happened
  • virtualbox_*.png - other Process Explorer pages for the VB.exe process
  • session_*.png - pages of the Session Information dialog for the VM
  • windbg_vadump.txt - !vadump of VB.exe just after noticing that it allocated 8 GB, before trying to stop the VM
  • windbg_stacks.txt - stacks of all threads, again before trying to stop the VM

Attachments

Ubuntu.vbox Download (8.8 KB) - added by cpatulea 3 years ago.
full vbox file of the VM in question
Ubuntu-2011-01-15-18-36-11.log Download (61.4 KB) - added by cpatulea 3 years ago.
log file after trying to stop the machine (added a comment at the time I tried to close the machine)
procexp.png Download (29.7 KB) - added by cpatulea 3 years ago.
Process Explorer list showing VB.exe at 8 GB
virtualbox_mem.png Download (8.7 KB) - added by cpatulea 3 years ago.
graph of CPU, memory and I/O of VB.exe when bug has just happened
virtualbox_disk.png Download (9.5 KB) - added by cpatulea 3 years ago.
virtualbox_image.png Download (12.2 KB) - added by cpatulea 3 years ago.
virtualbox_perf.png Download (12.7 KB) - added by cpatulea 3 years ago.
virtualbox_threads.png Download (11.3 KB) - added by cpatulea 3 years ago.
session_details.png Download (15.2 KB) - added by cpatulea 3 years ago.
pages of the Session Information dialog for the VM
session_runtime.png Download (13.5 KB) - added by cpatulea 3 years ago.
pages of the Session Information dialog for the VM
windbg_vadump.txt Download (186.1 KB) - added by cpatulea 3 years ago.
!vadump of VB.exe just after noticing that it allocated 8 GB, before trying to stop the VM
windbg_stacks.txt Download (18.6 KB) - added by cpatulea 3 years ago.
stacks of all threads, again before trying to stop the VM

Change History

Changed 3 years ago by cpatulea

full vbox file of the VM in question

Changed 3 years ago by cpatulea

log file after trying to stop the machine (added a comment at the time I tried to close the machine)

Changed 3 years ago by cpatulea

Process Explorer list showing VB.exe at 8 GB

Changed 3 years ago by cpatulea

graph of CPU, memory and I/O of VB.exe when bug has just happened

Changed 3 years ago by cpatulea

Changed 3 years ago by cpatulea

Changed 3 years ago by cpatulea

Changed 3 years ago by cpatulea

Changed 3 years ago by cpatulea

pages of the Session Information dialog for the VM

Changed 3 years ago by cpatulea

pages of the Session Information dialog for the VM

Changed 3 years ago by cpatulea

!vadump of VB.exe just after noticing that it allocated 8 GB, before trying to stop the VM

Changed 3 years ago by cpatulea

stacks of all threads, again before trying to stop the VM

comment:1 Changed 3 years ago by frank

Sounds like a duplicate of #7966. Could you check if  this build fixes your issue?

comment:2 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Should be fixed in VBox 4.0.4.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use