VirtualBox

Ticket #8087 (closed defect: worksforme)

Opened 3 years ago

Last modified 3 years ago

VirtualBox 4 unregistering vm but does not delete the settings file

Reported by: stealthc Owned by:
Priority: major Component: VM control
Version: VirtualBox 4.0.0 Keywords:
Cc: Guest type: Linux
Host type: Linux

Description

 http://pastebin.com/B92Z4fR8

Notice it won't remove it forcefully via the command VBoxManage unregistervm UUID --delete

To me that command should be pretty clear as it did what I wanted before I upgraded to the newest version of Vbox. Unregister and delete. Pretty simple. If you want a persistent settings file it should not be used with the --delete option (and perhaps something else).

Please fix this.

Change History

comment:1 Changed 3 years ago by frank

Well, from your provided screen shot it could be possible that you unregistered the VM before but did not pass the --delete switch. Next time you try to unregister this VM it is not part of the VBox registry anymore but the file is still there. Therefore it will fail to create that VM (because the VM settings file is already there) and it will fail to remove the VM (because VBox can't find this VM anymore).

I've just tried to reproduce this issue here. Created a VM with VBoxManage, removed it with VBoxManage, works fine here.

comment:2 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to worksforme
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use