VirtualBox

Ticket #8057 (reopened defect)

Opened 3 years ago

Last modified 3 months ago

First mouse click in virtual screen interpreted as drag

Reported by: mfrancis Owned by:
Priority: major Component: guest additions
Version: VirtualBox 4.0.0 Keywords:
Cc: Guest type: Linux
Host type: Mac OS X

Description (last modified by frank) (diff)

With an OSX host and Linux (Fedora 14) guest with guest additions installed, a mouse click into the guest that also transfers focus to the running VirtualBox host window causes an undesired drag from the previous mouse position within the guest (before host focus moved). This can have a number of undesirable effects on the guest depending on what exactly is on screen at the time.

Steps to reproduce:

  1. Install Fedora 14 and guest additions on an OSX host, and run in single-window mode with mouse integration enabled
  1. With a clean F14 desktop (no windows open), focus another host (OSX) window
  1. Left-click and hold at any position on the F14 desktop. A selection rectangle should be visible from the last position of the mouse within the guest before host focus was lost (the bug occurs even without holding, but the desktop selection rectangle shows what is happening clearly)

Expected behaviour: The click (or drag) should be experienced by the guest as starting from the position of the click into the guest desktop, not the position of the mouse prior to loss of host focus

Attachments

Fedora 14-2011-01-11-14-17-34.log Download (54.9 KB) - added by mfrancis 3 years ago.
VBox log

Change History

Changed 3 years ago by mfrancis

VBox log

comment:1 Changed 3 years ago by mfrancis

This bug is still present (and still annoying) with VB 4.0.10 and Fedora 15

comment:2 Changed 3 years ago by mickey

this issue happens to me with different linux guests, and is extremely annoying (thinking of virtualbox alternatives because of it). please make top priority!

comment:3 Changed 3 years ago by michael

Could you please do the following to help understand what is happening: start a Linux virtual machine in which you can trigger this with the environment variable "VBOX_RELEASE_LOG=main.e.l.l2.l3.f" set (this should cause lots of additional information to be added to the log file, including all mouse movement information), and then reproduce the issue with the "xev" application running to get information about mouse movement events from the point of view of the guest? Then attach the log file and post the "xev" output to this ticket? If necessary (and if you can be sure of getting them) you can truncate both to just the relevant parts.

comment:4 Changed 12 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
  • Description modified (diff)

No response, closing.

comment:5 Changed 6 months ago by boconnor

This happens to me on MacOSX host 10.8.3 and Mint 13 guest. It's easy to reproduce on multiple mac laptops and my desktop.

This is extremely annoying. The ticket is marked as "fixed" but this issue is not "fixed" in the latest release of VirtualBox for the mac.

Does anyone on the dev team for this project use a mac and run a Ubuntu/Fedora/Mint guest? I'm shocked that this is still a bug since it makes the application very tedious to use. I have to click the VirtualBox window on the Mac and then click inside the window to prevent this from happening.

Can someone from the team please reopen this issue?

comment:6 Changed 6 months ago by michael

  • Status changed from closed to reopened
  • Resolution fixed deleted

As you may have seen, the ticket was closed because at the time no one showed any continued interest in resolving the issue. If you are interested then you could try to gather the information that I requested from the previously affected people. I am not aware of anyone on the development team being affected by this.

comment:7 Changed 3 months ago by mvherweg

I want to add that this also happens to me with a slightly different setup: Latest virtualbox software running on windows 7 pro. The virtual machine is a Xubuntu 12.4 image. I connect to the VM from my Macbook Air (Mavericks) using Cord. (i.e., i have remote display enabled for the VM)

And i do get exactly the same issue as described here.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use