VirtualBox

Ticket #8052 (closed defect: duplicate)

Opened 3 years ago

Last modified 3 years ago

Kernel panic on host OpenSUSE when VM is using bond interface

Reported by: cduchenoy Owned by:
Priority: critical Component: network
Version: VirtualBox 4.0.0 Keywords:
Cc: Guest type: Linux
Host type: Linux

Description

I have a host running OpenSUSE 11.3 with severals guests running Linux VMs. This server uses 2 lan interfaces (1 Gb/s and 100 mB/s) configured as a bond0 active-passive interface. No problem whith all versions on virtualbox since 3.0, but kernel panic occured with version 4.0.0. I create an other server with minimal configuration and 1 interface bond0 with only 1 lan interface : same problem ! So I backgrade version with 3.4 and it works well again...

Attachments

qdisc_noqueue.patch Download (1.1 KB) - added by aleksey 3 years ago.
Fix for kernel panic when bridging to devices with no TX queue

Change History

comment:1 follow-up: ↓ 2 Changed 3 years ago by aleksey

I believe you have the same problem as described in #7879. Please apply the attached patch in the directory where you have installed VirtualBox with

sudo patch -p0 -i <path-to-qdisc_noqueue.patch>

then rebuild the modules with

sudo /etc/init.d/vboxdrv setup

Changed 3 years ago by aleksey

Fix for kernel panic when bridging to devices with no TX queue

comment:2 in reply to: ↑ 1 Changed 3 years ago by cduchenoy

Replying to aleksey:

Thank you. It's perfect. After applying the patch, I can now use the bond interface.

comment:3 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Thanks for the feedback. Closing this ticket as duplicate.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use