VirtualBox

Ticket #8049 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

Guru Meditation when booting with serial console in Linux

Reported by: magnusr Owned by:
Priority: major Component: VMM/RAW
Version: VirtualBox 4.0.0 Keywords:
Cc: Guest type: Linux
Host type: Windows

Description

Setting the bootup console in the linux kernel to ttyS0 (i.e. by adding "console=ttyS0" to the boot command line) causes a Guru Meditation with the message "fatal error in recompiler cpu: Trying to execute code with memory type addr_code=00000000f000f020 addend=0000000031ce0000 at 00000000f000ff53. (iHandlerMemType=0x38 iMMIOMe mType=0x30)" in the log.

I'm running Ubuntu 10.10 with kernel 2.6.35-24-generic on the guest, and Windows XP SP3 and VirtualBox 4.0.0 r69151 on the host.

The crash is very similar to the one I reported as 8028, but I'm not sure whether they are the same or not.

Attachments

VBox.log Download (167.7 KB) - added by magnusr 3 years ago.
VBox.png Download (2.1 KB) - added by magnusr 3 years ago.

Change History

Changed 3 years ago by magnusr

Changed 3 years ago by magnusr

comment:1 Changed 3 years ago by frank

  • Component changed from other to VMM/RAW

This bug will not happen if you boot your VM with VT-x enabled. The log file shows that VT-x is most probably there but not usable. The common reason is that VT-x was somehow disabled in the BIOS. Nevertheless this is a bug.

comment:2 Changed 3 years ago by magnusr

Hi,

I just noticed I made a mistake: I added "console=ttyS0" as a Grub parameter, instead of appending it to the Linux boot command line. Putting it the correct place made Linux boot properly (so the problem is not as severe as I thought), but still there should not be a guru meditation even when doing it wrong, right?

comment:3 Changed 3 years ago by frank

Right. What happens if you boot the configuration which would induce the Guru meditation and decrease the guest RAM to 768MB?

comment:4 Changed 3 years ago by frank

Any change with VBox 4.0.4?

comment:5 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

No response, closing.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use