VirtualBox

Ticket #8046 (closed defect: duplicate)

Opened 3 years ago

Last modified 3 years ago

VirtualBox 4.0.0 breaks OpenStep 4.2

Reported by: Dr. T Owned by:
Priority: major Component: other
Version: VirtualBox 4.0.0 Keywords: openstep, nextstep
Cc: Guest type: other
Host type: Mac OS X

Description

VirtualBox 4.0.0 appears to break compatibility with an OpenStep 4.2 guest. All versions of VirtualBox from 1.6.0 to 3.2.12 successfully ran OpenStep 4.2. VirtualBox 4.0.0 does not.

It is not clear what causes the problem. It might be related to display. OpenStep boot proceeds normally until such point as it switches from text (verbose) boot to graphics mode, at which point it simply goes to a black screen with a frozen mouse pointer drawn on it and does not move from there.

Change History

comment:1 Changed 3 years ago by Technologov

Added myself as CC

Where is it possible to get OpenStep ISO ?

-Technologov

comment:2 Changed 3 years ago by dhutch

This is almost certainly the same bug I reported in #7958. You can find log files there. You might want to merge these two reports.

I have an openstep.vdi (530 MB) that demonstrates the bug. I am willing to provide it to you if you tell me how. I even have an extra license to loan you while you work on this (to cover the legalities).

I also have an iso for the install, created using dd from the command line. But I cannot mount it in Mac OS X, and VirtualBox will not allow me to attach it. I have to use an actual CD for installation. I suspect this is another bug in VirtualBox, but I'm not sure at this point. It is possible that Linux can mount it since I have read that it understands the Openstep UFS format.

comment:3 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #7958.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use