VirtualBox

Ticket #8012 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

Guest freezes when doing complex jobs

Reported by: Perryg Owned by:
Priority: critical Component: other
Version: VirtualBox 4.0.0 Keywords: Guest freezes
Cc: Guest type: Solaris
Host type: Linux

Description

I have been having a huge problem with various guests doing complex jobs after Version 3.2.12. During various tasks like compiling, or even installing large packages that require a lot of read/writes. Logs keep talking about Changing the VM state from 'RUNNING' to 'SUSPENDING' and various 000c0781 failed with VERR_INVALID_PARAMETER and eventually will just stop working. This time I was adding the development packages to Solaris 11 Express and it got close to the end of installing and just stopped responding. The HDD icon was stuck in read (green lite only) and the only thing that works is the VirtualBox tabs at the top, but they don't seem to do anything either. Telling VBox to close,reset, causes a force quit from the host. It also seems worse in Solaris if you try to use SMP which I have been able to use since forever in previous versions of VirtualBox. I have tried with host I/O cache enabled and disabled and it makes no difference. I have tried with SCSI, SATA, and even IDE and the same thing happens. Log file attached.

Attachments

Solaris-11-E-64-2011-01-05-11-09-13.log Download (50.1 KB) - added by Perryg 3 years ago.

Change History

Changed 3 years ago by Perryg

comment:1 Changed 3 years ago by Perryg

Correction to previous statement.

Using IDE - ICH6 with host I/O Cache enabled seems to work better. Also removing the autoload of shared folders may have helped since they don't work anyway in Solaris 10u9 or Solaris 11 Express. Creating a ticket on this later.

comment:2 Changed 3 years ago by frank

Perry, still relevant?

comment:3 Changed 3 years ago by Perryg

Hi Frank,

Compiling VBox SVN r36277 in Solaris-11 does not show this problem. Took an hour and 20 minutes but it does complete. I am not sure but I believe the issue was resolved around the release of 4.0.2 or 4.0.4.

Logs do not show the constant reset either, so as far as I can tell it is TCO my friend!

Sorry I did not track that part better.

comment:4 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

No problem, thanks for retesting and your feedback! :-)

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use