VirtualBox

Ticket #8003 (closed defect: obsolete)

Opened 6 years ago

Last modified 7 weeks ago

Cryptic and confusing error message during vboxmanage modifyvm --guestmemoryballoon

Reported by: sbrickey Owned by:
Priority: minor Component: other
Version: VirtualBox 3.2.10 Keywords:
Cc: Guest type: Windows
Host type: Windows

Description (last modified by aeichner) (diff)

1) when setting guestmemoryballoon size, error messages are cryptic at best (I don't care about the DETAILS or CONTEXT) 2) when setting guestmemoryballoon size, maximum allowed value is rounded, causing confusion.


Step 1) try setting value of 2048MB

C:\Program Files\Oracle\VirtualBox>vboxmanage modifyvm "Domain Workstation" --guestmemoryballoon 2048 Oracle VM VirtualBox Command Line Management Interface Version 3.2.10 (C) 2005-2010 Oracle Corporation All rights reserved.

ERROR: Invalid memory balloon size: 2048 MB (must be in range [0, 1843] MB) Details: code E_INVALIDARG (0x80070057), component Machine, interface IMachine, callee IUnknown Context: "COMSETTER(MemoryBalloonSize)(ValueUnion.u32)" at line 1714 of file VBo xManageModifyVM.cpp

Ok, Step 2) try setting to stated maximum...

C:\Program Files\Oracle\VirtualBox>vboxmanage modifyvm "Domain Workstation" --guestmemoryballoon 1843 Oracle VM VirtualBox Command Line Management Interface Version 3.2.10 (C) 2005-2010 Oracle Corporation All rights reserved.

ERROR: Invalid memory balloon size: 1843 MB (must be in range [0, 1843] MB) Details: code E_INVALIDARG (0x80070057), component Machine, interface IMachine, callee IUnknown Context: "COMSETTER(MemoryBalloonSize)(ValueUnion.u32)" at line 1714 of file VBo xManageModifyVM.cpp

Ugh. Step 3) try setting just shy of stated maximum (assume rounding to be the cause)

C:\Program Files\Oracle\VirtualBox>vboxmanage modifyvm "Domain Workstation" --guestmemoryballoon 1842 Oracle VM VirtualBox Command Line Management Interface Version 3.2.10 (C) 2005-2010 Oracle Corporation All rights reserved.

C:\Program Files\Oracle\VirtualBox>

SUCCESS (finally)

PS: this feature (along with PageFusion) should be configurable within the UI... either by allowing multiple sliders in the memory page, or with another slider.

Change History

comment:1 Changed 7 weeks ago by aeichner

  • Status changed from new to closed
  • Resolution set to obsolete
  • Description modified (diff)

Please reopen if still relevant with a recent VirtualBox release.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use