VirtualBox

Ticket #7995 (closed defect: fixed)

Opened 3 years ago

Last modified 22 months ago

VB 4.0 OSX host linux guest crushing running java programs

Reported by: markster Owned by:
Priority: major Component: 3D support
Version: VirtualBox 4.0.4 Keywords:
Cc: Guest type: Linux
Host type: Mac OS X

Description (last modified by frank) (diff)

I have spend many days trying to figure out this with many possible configurations. I am running VB on Mac os X 10.6.5. I used VB previous releases and most recently version 3.2.10 for a long time. Primarily as development for Oracle tools - JDeveloper, Netbeans IDE and Tomcat 6.

After upgrading to latest VB 4.0 and installing additions the VB hangs randomly when executing Java apps (JDeveloper, Tomcat or NetBeans IDE). Nothing shows in the vbox.log.

Do not have any issues with VB version 3.2.10.

Attachments

Suse-Oracle64-2011-02-18-09-25-08.log Download (72.1 KB) - added by markster 3 years ago.
VBox 4.0.4 with GUestAdditions 3.0.12
Screen shot 2011-05-06 at 7.35.29 AM.jpg Download (387.1 KB) - added by markster 3 years ago.
Suse-Linux64-2011-05-06-07-36-16.log Download (80.2 KB) - added by markster 3 years ago.
This is the log file after JDeveloper 11.1.1.4 hung the VBox 4.0.7

Change History

comment:1 Changed 3 years ago by frank

Ticket #8350 reports that this is probably related to the guest additions. Can you confirm this? Could you install VBox 4.0.4 but take the guest additions from 3.2.12 which are available from  here.

comment:2 Changed 3 years ago by markster

Just tried the recommended configuration and the problem still exists. What I did..

  1. Started standalone WLS 10.3.4 and used the console.
  2. Started JDeveloper - (started ok).
  3. Started JDeveloper integrated WLS - started ok.
  4. Stopped (1) - ok.
  5. From JDeveloper selected to lounch WLS console - HANG.

Changed 3 years ago by markster

VBox 4.0.4 with GUestAdditions 3.0.12

comment:3 Changed 3 years ago by markster

UPDATE.

Unchecking 3D support and all is working fine with this configuration.

comment:4 Changed 3 years ago by frank

  • Component changed from other to 3D support

Thanks for this information.

comment:5 Changed 3 years ago by frank

  • Version changed from VirtualBox 4.0.0 to VirtualBox 4.0.4

comment:6 Changed 3 years ago by markster

Update!!

The issue is still there. After running VB 4.0.4 and GuestAdditions 3.0.12 I tried re-installing JDeveloper. The system crushed during installation. Tried few times and finally installed the tool, but than during JDeveloper execution it still crushed/hangs the VBox.

Please keep this bug open or unresolved.

-mark

comment:7 Changed 3 years ago by frank

Could you check if  this test build still shows this behavior?

comment:8 Changed 3 years ago by markster

Just tried new version (4.0.7) and started in the following order. 1.Oracle-XE 2.Oracle FMW (weblogic server) 3.Oracle FMW (soa domain)

  1. JDeveloper.

The JDeveloper would intermittently freeze the VBox.

Changed 3 years ago by markster

Changed 3 years ago by markster

This is the log file after JDeveloper 11.1.1.4 hung the VBox 4.0.7

comment:9 Changed 3 years ago by markster

After unchecking PAE support for the VBox and using 64-bit JDK for JDeveloper I no longer experience the problem.

-mark

comment:10 Changed 22 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
  • Description modified (diff)

Please reopen if still relevant with VBox 4.1.18. In that case please also try with the PIIX3 chipset as the ICH9 chipset is still marked as experimental.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use