VirtualBox

Ticket #7976 (closed defect: fixed)

Opened 3 years ago

Last modified 19 months ago

4.0 on linux host segfaults after resume from disk

Reported by: bleun Owned by:
Priority: major Component: other
Version: VirtualBox 4.0.0 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description (last modified by frank) (diff)

Running VirtualBox 4.0 on Ubuntu 10.10 host results in a segfault in VBoxVMM.so if the host resumes from a suspend to disk.

Suspend/Resume to ram works flawless, 3.2.12 showed the same error, for relevant info from /var/log/messages see attachements.

Attachments

messages Download (3.3 KB) - added by bleun 3 years ago.
VBox.log Download (50.2 KB) - added by bleun 3 years ago.
VBox.2.log Download (44.0 KB) - added by john.doe 3 years ago.
VBox.3.log Download (69.0 KB) - added by john.doe 3 years ago.
VBox.log.gz Download (35.2 KB) - added by john.doe 3 years ago.
VBox.log.2.gz Download (36.1 KB) - added by john.doe 3 years ago.
Log for other machine (slack 13.1, VBox 4.0.6)

Change History

Changed 3 years ago by bleun

Changed 3 years ago by bleun

comment:1 Changed 3 years ago by frank

Any chance to provide a  core dump? If so, mail me at frank _dot_ mehnert _at_ oracle _dot_ com (I can tell you a server for uploading the file).

comment:2 Changed 3 years ago by john.doe

Similar error when resuming Linux guests in VirtualBox 4.0.2, though this worked fine in VirtualBox 3.1

Changed 3 years ago by john.doe

comment:3 Changed 3 years ago by frank

Still relevant with VBox 4.0.6?

comment:4 Changed 3 years ago by john.doe

Have installed VBox 4.0.6. KUbuntu guest seems to resume ok, but Slackware guest doesn't resume, even after updating Guest additions from 4.0.2 to 4.0.6. Virtual machine doesn't return guru meditation now, but it shows static picture of guest screen and there is no response to keyboard and mouse.

Changed 3 years ago by john.doe

comment:5 Changed 3 years ago by john.doe

Uploaded core dump of the meditating VM to:  http://www.sendspace.com/file/7f4sr0 ('kill -4' didn't work, so I used 'VBoxManage debugvm dumpguestcore' instead)

comment:6 Changed 3 years ago by frank

john.doe, which Linux distribution is running on your host?

comment:7 Changed 3 years ago by frank

Hmm, actually that core file is not usable. You say that kill -4 <process id> did not work, does that mean that the process did not terminate? Are you sure that you specified the correct process ID?

comment:8 Changed 3 years ago by john.doe

Host distro is Slackware 13.0. I retried and managed to make a dump with kill this time -  http://www.sendspace.com/file/ve1xh8

comment:9 Changed 3 years ago by frank

I get some information from your core dump but as I don't have Slackware 13 here, the backtraces are not entirely correct. Do you still have the corresponding VBox.log file available? Also, can you reproduce the hanging process when you try to resume that VM?

Btw, your problem is very different from the original problem...

comment:10 Changed 3 years ago by john.doe

Yes, I have the log, and it also contains some dumps since I chose Ignore in the Guru Meditation box. The VM doesn't hang on resume after pause, it only hangs after starting from saved state. Yes, problem is different, I see. Initially, I searched the bugtracker and this ticket was found, so I decided to complement it...

Changed 3 years ago by john.doe

comment:11 Changed 3 years ago by john.doe

If it is helpful by any means: the crash also occurs on other machine (host - Slackware 13.1). Maybe the problem is caused by the guest OS?..

Changed 3 years ago by john.doe

Log for other machine (slack 13.1, VBox 4.0.6)

comment:12 Changed 19 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
  • Description modified (diff)

Please reopen if still relevant with VBox 4.1.22.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use