VirtualBox

Changes between Initial Version and Version 1 of Ticket #7972, comment 7


Ignore:
Timestamp:
08/21/12 14:08:24 (20 months ago)
Author:
gquincy
Comment:

Legend:

Unmodified
Added
Removed
Modified
  • Ticket #7972, comment 7

    initial v1  
    11Replying to [ticket:7972 lnoland]: 
    2 > ''Note: I have not attached a session log file as attempting to install an extension pack, predictably, does not appear to generate anything in the session log for a VM.  I have attempted the installation both without and with VMs running.'' 
    3 >  
     2 
    43> I installed !VirtualBox 4.0.0 onto Windows 7 Professional and attempted to install the extension pack: '''Oracle_VM_VirtualBox_Extension_Pack-4.0.0-69151.vbox-extpack''' 
    54> The attempt failed with: 
     
    87> ''a screencap of the error dialog is attached.'' (''NOTE: My boot drive (C:) is a small solid-state drive so I have the user account directories on my G: drive and install most software there as well.'') 
    98>  
    10 > As the error suggests "access denied" and the host is Windows 7, I immediately suspected UAC, however, I am not so sure of that now.  I searched the forums for anyone else experiencing the error -- I did find someone else and their error appeared to be identical to mine but, in their case, they have VBox loaded on a Windows XP host, so UAC seems an unlikely contributor. 
    11 >  
    12 > I did verify that it seems to be actually creating the temporary directory (I did this by opening the !ExtensionPacks subdirectory in Windows Explorer and visually watching it as I attempted the installation -- a new folder appeared briefly then disappeared again followed immediately by the appearance of the error dialog). 
    13 >  
    14 > I have verified that the MD5 checksum for the extension pack matches the one published on your website.  I can also open that file using 7-zip and it appears reasonable in format and content (as best as I can tell). 
    15 >  
    16 > I tried installing the extension pack in as many ways as I could imagine: doubleclicking on the file itself; adding it using the preferences dialog in !VirtualBox Manager; running !VirtualBox manager both as an administrator and as a non-elevated administrative user; installing from an elevated command prompt using VBoxManage.exe; etc.  In each case the results were exactly the same.  I even tried rebooting my machine and then running the scenarios again. 
    17 >  
    18 > Since it was suggesting an access problem, and knowing that Windows 7 has some restrictions on making modifications to the "Program Files" directory and subdirectories ( I am not sure exactly what those restrictions are but I know that in some cases things wind up in a virtual directory instead of the intended target) I tried a long shot and deleted the !ExtensionPacks directory then replaced it with a symbolic link to a directory I created in G:\Users\Public which had full access by the special user "!EveryOne" so there should not have been any access problems so far as I know -- the results were exactly the same as before so I reversed my changes. 
    19 >  
    20 > I have checked the Windows Logs in the event viewer -- there are no application errors, system errors, nor security audit failures, corresponding to the failed installation. 
    21 >  
    22 > I am pretty well tapped out of other ideas of things to try as workarounds.  If there is any other information you need please let me know.  Thanks in advance for any assistance you can provide in resolving this. 
    23 >  
    24 >  
    25 >  
     9 
    2610 
    2711 

www.oracle.com
ContactPrivacy policyTerms of Use