VirtualBox

Ticket #7958 (new defect)

Opened 3 years ago

Last modified 3 years ago

Openstep 4.2 does not boot correctly in VirtualBox 4.0.0. It works correctly in 3.2.12.

Reported by: dhutch Owned by:
Priority: major Component: other
Version: VirtualBox 4.0.4 Keywords: Openstep mouse
Cc: Guest type: other
Host type: other

Description

In VB 4.0.0, Openstep hangs for almost a minute after printing that Power Management is Enabled. It reports that it cannot find the PS2 mouse. After completing the reboot, the Window Manager fails to load and no log-in screen is produced.

This is a regression from 3.2.12, where it works correctly.

I am attaching logs from both 4.0.0 and 3.2.12. I've also attached a tiff showing the system messages from the failed boot that it wrote to disk. It does not show the message about the PS2 mouse which is printed on-screen during the boot process.

It is possible that this is similar to the old (and fixed) bug report #3152 since the resulting screen is similar.

Attachments

VBox4.log Download (55.0 KB) - added by dhutch 3 years ago.
4.0.0 Log File
VBox3.log Download (52.0 KB) - added by dhutch 3 years ago.
3.2.12 Log File
OpenstepError.tiff Download (221.1 KB) - added by dhutch 3 years ago.
Screen Shot of Openstep system messages
VBox-4-0-4.log Download (57.1 KB) - added by dhutch 3 years ago.
VBox 4.0.4 log
VBox-4-0-6.log Download (57.1 KB) - added by dhutch 3 years ago.
Vbox.log from 4.0.6
VBox-4.0.8-withVTX.log Download (57.4 KB) - added by dhutch 3 years ago.
VBox 4.0.8 with VT-x
VBox-4.0.8-noVTX.log Download (53.6 KB) - added by dhutch 3 years ago.
VBox 4.0.8 without VT-x

Change History

Changed 3 years ago by dhutch

4.0.0 Log File

Changed 3 years ago by dhutch

3.2.12 Log File

Changed 3 years ago by dhutch

Screen Shot of Openstep system messages

comment:1 Changed 3 years ago by frank

Any change with VBox 4.0.4?

comment:2 Changed 3 years ago by dhutch

No change with VBox 4.0.4. It still pauses for a minute mid-boot, fails to load the PS2 mouse driver, and doesn't display the login panel.

comment:3 Changed 3 years ago by frank

  • Priority changed from critical to major
  • Version changed from VirtualBox 4.0.0 to VirtualBox 4.0.4

Could you attach a VBox.log file for a 4.0.4 session?

Changed 3 years ago by dhutch

VBox 4.0.4 log

Changed 3 years ago by dhutch

Vbox.log from 4.0.6

comment:4 Changed 3 years ago by dhutch

There is no change in VBox 4.0.6. The problem remains. I've attached the 4.0.6 log.

comment:5 Changed 3 years ago by frank

Is that OpenStep version freely available for testing?

Changed 3 years ago by dhutch

VBox 4.0.8 with VT-x

Changed 3 years ago by dhutch

VBox 4.0.8 without VT-x

comment:6 Changed 3 years ago by dhutch

I've been playing with VirtualBox 4.0.8.

My Openstep implementation works in 4.0.8 with VT-x disabled. So I now have a working solution.

It still does not work with VT-x enabled which is how it was created in VirtualBox 3. If you want to investigate why that stopped working, I can loan you the .vdi with an installation that illustrates the problem. It is 530 MBytes and contains no personal information. If you want it, let me know how to get it to you.

I've attached the logs from 4.0.8 with and without VT-x enabled.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use