VirtualBox

Ticket #7933 (closed defect: fixed)

Opened 3 years ago

Last modified 11 months ago

Opening Visual C++ Express 2010 in VirtualBox 4.0.0 r69151 causes infinite resolution switching loop

Reported by: tha_lime Owned by:
Priority: major Component: other
Version: VirtualBox 4.0.0 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description (last modified by frank) (diff)

Description

When you open Visual C++ Express 2010  http://www.microsoft.com/express/Downloads/#2010-All in VirtualBox 4.0.0 r69151, the screen starts to flicker while the resolution is changed from the current resolution to 640x480 several times per second.

The VirtualBox log file shows entries like this:

00:03:53.587 Guest Log: VBoxDisp[0]: VBVA enabled
00:03:53.587 Display::handleDisplayResize(): uScreenId = 0, pvVRAM=00007f9f4b462000 w=640 h=480 bpp=16 cbLine=0x500, flags=0x1
00:03:53.596 Display::handleDisplayResize(): uScreenId = 0, pvVRAM=00007f9f4b462000 w=640 h=480 bpp=16 cbLine=0x500, flags=0x1
00:03:53.655 Guest Log: VBoxDisp[0]: VBVA enabled
00:03:53.655 Display::handleDisplayResize(): uScreenId = 0, pvVRAM=00007f9f4b462000 w=640 h=480 bpp=32 cbLine=0xA00, flags=0x1
00:03:53.659 Display::handleDisplayResize(): uScreenId = 0, pvVRAM=00007f9f4b462000 w=640 h=480 bpp=32 cbLine=0xA00, flags=0x1
00:03:53.716 Guest Log: VBoxDisp[0]: VBVA enabled
00:03:53.716 Display::handleDisplayResize(): uScreenId = 0, pvVRAM=00007f9f4b462000 w=1265 h=918 bpp=32 cbLine=0x13C4, flags=0x1
00:03:53.721 Display::handleDisplayResize(): uScreenId = 0, pvVRAM=00007f9f4b462000 w=1265 h=918 bpp=32 cbLine=0x13C4, flags=0x1
00:03:54.089 Guest Log: VBoxDisp[0]: VBVA enabled
00:03:54.089 Display::handleDisplayResize(): uScreenId = 0, pvVRAM=00007f9f4b462000 w=640 h=480 bpp=16 cbLine=0x500, flags=0x1
00:03:54.106 Display::handleDisplayResize(): uScreenId = 0, pvVRAM=00007f9f4b462000 w=640 h=480 bpp=16 cbLine=0x500, flags=0x1
00:03:54.292 Guest Log: VBoxDisp[0]: VBVA enabled

This issue looks similar to #5597, but is initiated by starting Visual Studio 2010.

Environment

Host: Ubuntu AMD64 10.10 with ATI Radeon adapter. Guest: Windows XP 32 bit, service pack 3 Tried with both single and dual CPU, also with and without 3d acceleration.

Workaround

None yet. But you are able to close Visual C++ Express 2010 with ALT+F4. (Or with the mouse if you are really quick in between the resolution changes). When the program has shut down, VirtualBox is changing back to the normal resolution, and the flickering stops.

Attachments

Windows XP (computername)-2010-12-28-16-26-14.log Download (54.2 KB) - added by tha_lime 3 years ago.
VirtualBox log file

Change History

Changed 3 years ago by tha_lime

VirtualBox log file

comment:1 Changed 3 years ago by tha_lime

Sorry, this issue is similar to issue #6108, not #5579 as mentioned in the report.

Also I have seen similar this when starting java applications earlier, and also sometimes when printing PDF files from a RDP session with redirected printers on VirtualBox 3.x. However, Visual Studio has been working until now.

Just a shot in the wild: can the issue be related to the OS changing the resolution of the timer? I know Java makes Windows do this (raising the resolution to 1000Hz.)

comment:2 Changed 3 years ago by tha_lime

I can confirm the same thing (resolution changing down and up again) is happening when launching Java. However, it only happens once, not in a loop like the issue is describing.

comment:3 Changed 3 years ago by tha_lime

Another update: If I start Visual C++ Express as administrator (I am not local admin on the workstation), I only notice one flicker, not a infinite loop.

comment:4 Changed 11 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
  • Description modified (diff)

Please reopen if still relevant with VBox 4.2.12.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use