VirtualBox

Ticket #7886 (closed defect: duplicate)

Opened 3 years ago

Last modified 3 years ago

VM with hard disks on USB hard disk will not boot

Reported by: cortana Owned by:
Priority: major Component: other
Version: VirtualBox 4.0.0 Keywords:
Cc: Guest type: Linux
Host type: Windows

Description

After upgrading to VirtualBox 4.0, a virtual machine that has its hard disks on a USB hard disk will no longer boot.

The guest is Linux 2.6.32; it gets as far as printing the following:

sr 0:0:0:0: Attached scsi generic sg0 type 5 sd 2:0:0:0: Attached scsi generic sg1 type 0 sd 3:0:0:0: Attached scsi generic sg2 type 0

and then hangs.

Attachments

emelia-2010-12-23-01-30-26.log Download (49.5 KB) - added by cortana 3 years ago.
log file

Change History

Changed 3 years ago by cortana

log file

comment:1 Changed 3 years ago by cortana

If I move the vm's hard disk to an internal drive, and boot it up, then it gets further in the boot sequence: as far as

usbhid: v2.6:USB HID core driver

before hanging. Disabling the USB controller then allows the machine to get a little further before hanging--as far as initramfs scripts.

comment:2 Changed 3 years ago by cortana

I think this is another dupe of #8033. Enabling the IO APIC Controller setting fixed the VM's ability to boot.

comment:3 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Exactly! Thanks for the hint.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use