VirtualBox

Ticket #7884 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

VirtualBox 4.0 final Manager occasional crash, Qt related?

Reported by: mhanor Owned by:
Priority: major Component: other
Version: VirtualBox 4.0.0 Keywords: manager crash
Cc: Guest type: other
Host type: Windows

Description

I think this is a regression from 3.x and even from 4.0 beta3. I've never experienced it before that. I only know that it happens when closing the Manager. It happened to me at least 2 times, using identical steps: creating an XP 32 bit VM, modifying some settings in the VM settings window, without starting the VM, followed by an idle time, leaving the Manager opened and working on something else on the PC (for several minutes, unrelated to VB), then trying to close the Manager, followed by instant crash. At least two of the crash backtraces that I've managed to observe (including the current dump), pointed to Qt. I've seen one other backtrace that pointed to ntdll or kernel32.dll (I don't remember which one). I can't reproduce it at will, I don't understand it yet.

My system: Windows XP SP3 32 bit

Full crash minidump, pageheap enabled (full), disabled heap coalesce on free (trying to catch some other type of crash):
 http://www.sendspace.com/file/7gbgpa

Change History

comment:1 Changed 3 years ago by frank

Still reproducible with VBox 4.0.4?

comment:2 Changed 3 years ago by mhanor

I haven't encountered it since 4.0.0 was released

comment:3 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Thanks.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use