VirtualBox

Opened 14 years ago

Closed 14 years ago

#7879 closed defect (fixed)

Linux host freezes when started bridged network to a kernel bridge device => Fixed in SVN

Reported by: Ivo Smits Owned by:
Component: network Version: VirtualBox 4.0.0
Keywords: Cc:
Guest type: other Host type: Linux

Description

My linux host freezes right after I start a guest that uses bridged networking, bridged to a kernel bridge device (br0, bridge-utils/brctl). It works fine with other devices (eth, tap). This problem did not exist in previous versions of VirtualBox (3.x).

I'm running Ubuntu 10.04 LTS - Lucid Lynx, x64. I'm using a stock Ubuntu kernel version 2.6.32-27-generic #49-Ubuntu SMP.

I've tried to disable VT-x, CSAM, PATM, raw ring 0 and raw ring 3 using VBoxSDL, but this did not help.

The VBox.log file is empty. There's no console output from VirtualBox and syslog only tells me that the bridge device has just entered promiscuous mode.

Attachments (4)

vboxnetflt.ko (40.5 KB ) - added by Ivo Smits 14 years ago.
vboxnetflt.ko on ubuntu kernel 2.6.32-27-generic, built by dkms
vboxnetflt.2.ko (40.5 KB ) - added by Guizmo 14 years ago.
vboxnetflt.ko on ubuntu kernel 2.6.32-27-generic, built by dkms (Guizmo)
vboxnetflt3.ko (33.4 KB ) - added by bmeunier 14 years ago.
vboxnetflt.ko on fedora 14 kernel 2.6.35.10-74.fc14.x86_64, built by dkms (bmeunier)
qdisc_noqueue.patch (1.1 KB ) - added by Aleksey Ilyushin 14 years ago.
Fix for devices without TX queue

Download all attachments as: .zip

Change History (14)

comment:1 by Ivo Smits, 14 years ago

The freeze has now also occured with a NIC bridged to an (unused) tap device, while the guest was loading a large file from a network file share.

Also, the capslock led lights up when the host freezes.

comment:2 by Guizmo, 14 years ago

I'm having exactly the same issue:

Host system: Ubuntu 10.04 LTS (kernel: 2.6.32-27-generic)

Vbox: VirtualBox 4.0.0

I created a bridge device with bridge-utils, set it a static ip, configured VM's network adapter to connect to the br0 device (win xp) and after a few seconds the whole host system hangs and the capslock and numlock leds light up...

UFO, do you have some news about it?

comment:3 by Ivo Smits, 14 years ago

Looks like this might be a duplicate of #7908. I will attach my vboxnetflt.ko as requested in the other ticket.

Guizmo: using a tap device to bind to, instead of a bridge, works somewhat better. It crashes under load, but not immediately. I'm currently successfully using the VDE2 backend, which runs in userspace. The vde_switch then binds to a tap interface on the host.

by Ivo Smits, 14 years ago

Attachment: vboxnetflt.ko added

vboxnetflt.ko on ubuntu kernel 2.6.32-27-generic, built by dkms

by Guizmo, 14 years ago

Attachment: vboxnetflt.2.ko added

vboxnetflt.ko on ubuntu kernel 2.6.32-27-generic, built by dkms (Guizmo)

comment:4 by Guizmo, 14 years ago

Thanks for the update UFO.

I'll try your sugestion or maybe go back to 3.2...

Here is my vboxnetflt.ko

p.s.: Do you know if this problem occures on mandriva with the same kernel?

comment:5 by bmeunier, 14 years ago

This occurs on Fedora 14 host (kernel 2.6.35.10-74.fc14.x86_64.) I tried with centos 5.5 and ubuntu 10.10 guests. If the guest use a bridge, the host freeze with black screen and it's not possible to change the level of the host (CTRL+ALT+FF3 for exemple). Whithout bridge, no crash happens.

by bmeunier, 14 years ago

Attachment: vboxnetflt3.ko added

vboxnetflt.ko on fedora 14 kernel 2.6.35.10-74.fc14.x86_64, built by dkms (bmeunier)

comment:6 by Aleksey Ilyushin, 14 years ago

#7908 is indeed a duplicate of this ticket. I've uploaded the patch that solves the problem there. I am attaching it here as well. I'll mark #7908 as a duplicate.

by Aleksey Ilyushin, 14 years ago

Attachment: qdisc_noqueue.patch added

Fix for devices without TX queue

comment:7 by Aleksey Ilyushin, 14 years ago

Apply the patch in the directory where you have installed VirtualBox with

patch -p0 -i <path-to-qdisc_noqueue.patch>

then rebuild the modules with

sudo /etc/init.d/vboxdrv setup

in reply to:  7 comment:8 by bmeunier, 14 years ago

Replying to aleksey:

Apply the patch in the directory where you have installed VirtualBox with

patch -p0 -i <path-to-qdisc_noqueue.patch>

then rebuild the modules with

sudo /etc/init.d/vboxdrv setup

It solves the problem. The patch works.

Thank you

comment:9 by Frank Mehnert, 14 years ago

Summary: Linux host freezes when started bridged network to a kernel bridge deviceLinux host freezes when started bridged network to a kernel bridge device => Fixed in SVN

comment:10 by Frank Mehnert, 14 years ago

Resolution: fixed
Status: newclosed

Fixed in VBox 4.0.2.

Note: See TracTickets for help on using tickets.

© 2023 Oracle
ContactPrivacy policyTerms of Use