VirtualBox

Ticket #7866 (closed defect: duplicate)

Opened 3 years ago

Last modified 3 years ago

CLI tools should be installed in /usr/local/bin on Mac OS X, not /usr/bin

Reported by: Camillo Owned by:
Priority: minor Component: installer
Version: VirtualBox 3.2.12 Keywords:
Cc: Guest type: other
Host type: Mac OS X

Description

/usr/bin, /usr/lib etc. are owned by the OS, much like /System/Library. Third-party applications should install into /usr/local/bin (and /usr/local/lib, /Library, etc.); the /usr/local hierarchy is completely dedicated to user-installed applications (Mac OS X does not put anything there). This avoids conflicts and ensures that applications installed by the user are not disturbed by system upgrades. Note that, like /usr/bin, /usr/local/bin is also in the default PATH, so users will still be able to run the programs from the shell immediately.

Change History

comment:1 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #6639.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use