VirtualBox

Ticket #7805 (closed defect: wontfix)

Opened 3 years ago

Last modified 2 years ago

Select and middle-click paste in X11 not supported -> won't fix

Reported by: lyallp Owned by:
Priority: major Component: clipboard
Version: VirtualBox 3.2.12 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

Copy text from Host Linux system (xterm, select text) does not paste into windows XP Guest system. Copy text from Guest Windows XP system to Linux Host (via right click) works.

VirtualBox 3.2.12 r68302 PUEL edition. Host: Linux lyalls-pc 2.6.35-gentoo-r12 #1 SMP PREEMPT Sun Dec 5 12:30:59 CST 2010 i686 Intel(R) Core(TM)2 Quad CPU Q9400 @ 2.66GHz GenuineIntel GNU/Linux Guest: Windows XP Pro, fully patched with very little other software installed. Guest Additions updated.

X System of Host: xorg-server-1.7.7-r1 (Gentoo versioning) Window Manager of Host: Fluxbox-1.1.1-r2 (Gentoo versioning)

Change History

comment:1 Changed 3 years ago by lyallp

I didn't mention but this has happened on two completely different Linux hosts and with two very different Windows XP Pro Guests. (work and home :) )

comment:2 Changed 3 years ago by michael

What about with Linux guests? (To check whether the problem is the host or the guest.)

comment:3 Changed 3 years ago by lyallp

A Gentoo guest (guest details further down), with Gentoo host (as described earlier)

Xterm in Host, select text with cursor, right click in guest, pasted the last copy/paste from the other Windows XP guest, which was still running. Guest is also running fluxbox window manager (1.1.1-r1) with xorg-server (1.7.7-r1) (gentoo version numbers)

Selected text in Gentoo guest Xterm, right click in Host xterm, text that was previously selected in Host is pasted, not the selected text in the guest.

Fresh build of gentoo kernel.

Gentoo guest has Additions 3.2.12 guest additions (VBoxLinuxAdditions-x86.run)

Also, Solaris 10 u8, Guest Additions 3.2.12 (SunOS unknown 5.10 Generic_141445-09 i86pc i386 i86pc) - an appliance downloaded from Oracle.

WM is Sun Java Desktop system. Running a Gnome Terminal 2.6.1.

Select text in Host xterm, right click in guest xterm, pastes last pasted text, not the selected host text.

Use guest gnome terminal edit->Paste, same.

Select text in Guest gnome terminal, right click in host xterm, pasts last pasted text (selected text in host xterm).

Select text in Guest gnome terminal, use Edit->Copy, then right click in host xterm, guest text is pasted in. (Works!)

Gentoo Guest details follow...

Linux gentoo-vc 2.6.35-gentoo-r12 #1 SMP Thu Dec 9 10:49:47 CST 2010 i686 Intel(R) Core(TM)2 Duo CPU E6550 @ 2.33GHz GenuineIntel GNU/Linux

Portage 2.1.9.24 (default/linux/x86/10.0/desktop, gcc-4.4.4, glibc-2.11.2-r3,
2.6.35-gentoo-r12 i686)
=================================================================
System uname: Linux-2.6.35-gentoo-r12-i686-Intel-R-_Core-
TM-2_Duo_CPU_E6550_@_2.33GHz-with-gentoo-1.12.14
Timestamp of tree: Sun, 05 Dec 2010 22:15:01 +0000
app-shells/bash:     4.1_p7
dev-java/java-config: 2.1.11-r1
dev-lang/python:     2.6.5-r3, 3.1.2-r4
dev-util/cmake:      2.8.1-r2
sys-apps/baselayout: 1.12.14-r1
sys-apps/sandbox:    2.3-r1
sys-devel/autoconf:  2.13, 2.65-r1
sys-devel/automake:  1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.4.4-r2
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.10
sys-devel/make:      3.81-r2
virtual/os-headers:  2.6.30-r1 (sys-kernel/linux-headers)
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="* -@EULA"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -mtune=core2 -march=core2 -fomit-frame-pointer -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ 
/etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/sandbox.d 
/etc/terminfo"
CXXFLAGS="-O2 -mtune=core2 -march=core2 -fomit-frame-pointer -pipe"
DISTDIR="/portage/distfiles"
FEATURES="assume-digests binpkg-logs collision-protect distlocks fixlafiles 
fixpackages news nostrip parallel-fetch protect-owned sandbox sfperms strict 
unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv 
usersandbox"
GENTOO_MIRRORS="http://linuxcoe.corp.hp.com/LinuxCOE/Gentoo 
ftp://mirror.internode.on.net/pub/gentoo ftp://mirror.pacific.net.au/linux
/Gentoo http://mymirror.asiaosc.org/gentoo/ http://www.zentek-
international.com/mirrors/gentoo/ http://open-systems.ufl.edu/mirrors/gentoo 
http://www.ibiblio.org/pub/Linux/distributions/gentoo"
LANG="C"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j3"
PKGDIR="/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times 
--compress --force --whole-file --delete --stats --timeout=180 
--exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/tmp"
PORTDIR="/portage"
PORTDIR_OVERLAY="/portage/local"
SYNC="rsync://mirror.internode.on.net/gentoo-portage"
USE="X a52 aac acl acpi alsa apache2 avahi berkdb bindist bluetooth branding 
bzip2 cairo cdb cddb cdparanoia cdr cli consolekit cracklib crypt css cups 
cxx daap dbus dri dts dvb dvd dvdr emboss encode exif fam ffmpeg firefox flac 
fortran gdbm gif gnome gpm gtk hal iconv ipv6 java javascript joystick jpeg 
jpeg2k kde latin1 lcms ldap libnotify lirc mad mdnsresponder-compat mikmod 
mmxext mng modules mp3 mp4 mpeg mplayer mudflap mysql ncurses nls nptl 
nptlonly nsplugin ogg opengl openmp oss pam pango pcre pdf perl png posix 
ppds pppd python qt3support qt4 readline rss samba sdl server session spell 
sqlite sse3 ssl startup-notification svg sysfs tcpd threads tiff transcode 
truetype type1 unicode usb v4l vcd vorbis wma x264 x86 xcb xcomposite xine 
xml xorg xulrunner xv xvid xvmc zlib" ALSA_CARDS="ali5451 als4000 atiixp 
atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 
es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx 
via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare 
dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter 
mmap_emul mulaw multi null plug rate route share shm softvol" 
APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd 
authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile 
authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd 
deflate dir disk_cache env expires ext_filter file_cache filter headers ident 
imagemap include info log_config logio mem_cache mime mime_magic negotiation 
proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so 
speling status unique_id userdir usertrack vhost_alias" COLLECTD_PLUGINS="df 
interface irq load memory rrdtool swap syslog" 
ELIBC="glibc" 
GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt 
gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore 
rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" 
INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad 
cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" 
PHP_TARGETS="php5-2" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="vesa 
fbdev" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset 
ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark 
ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, 
LINGUAS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, 
PORTAGE_RSYNC_EXTRA_OPTS

comment:4 Changed 3 years ago by michael

We support copy and paste but not select and paste, as that is X11-specific and VirtualBox is cross-platform. As a bonus we do let you middle-click paste things you have copied.

comment:5 Changed 3 years ago by lyallp

It used to work. Also, using X, select/middle click IS how copy/paste is done. X is one of the platforms that VB 'crosses', hence my treating it as a defect. As an added bonus, I supplied test data for 3 different guests with two different results.

comment:6 Changed 3 years ago by michael

As the person who implemented our X11 clipboard support I am not aware of middle-click select and paste ever having worked across the VM boundary. And regarding the way things are done on X11, you might want to look at  http://en.wikipedia.org/wiki/X_Window_selection, particularly the "Clipboard" section. This is not something new in the X11 world - going by the ICCCM it dates back to at least X11R2.

comment:7 Changed 3 years ago by lyallp

After skimming the article you linked, I saw about the clipboard managers. I installed xclipboard. I have tweaked xterm (.Xdefaults xterm*selectToClipboard:true) and emacs (setvar x-select-enable-clipboard 1) to both use the clipboard, which I can see happening, thanks to xclipboard.

If I copy text inside a windows XP Pro VM (in notepad), it appears in the clipboard, and is paste'able in both the xterm and emacs in the host Linux system.

However, if I select text in the host system xterm/emacs, either by selection or in Emacs case, copying using M-w, the data appears in the clipboard but is not paste'able in the Windows VM (using notepad, edit->paste nor ctrl-v).

Further, if I select and copy (ctrl-c) text in Firefox, the text appears in xclipboard, as expected and IS paste'able into the Windows VM.

In summary. xterm and Emacs put text in the clipboard which windows notepad is unable to process. Firefox, also puts text in the clipboard which windows notepad IS able to process.

Is this expected behaviour? To me, it appears inconsistent.

comment:8 Changed 3 years ago by michael

If I start an XTerm with -xrm xterm*selectToClipboard:true on my Ubuntu 10.10 host then whatever I select in it with the mouse is pastable into an XP guest.

comment:9 Changed 3 years ago by lyallp

I placed the selectToClipboard in my .Xdefault file. It seems to be behaving. I will investigate a bit further early in the new year.

comment:10 Changed 2 years ago by michael

  • Status changed from new to closed
  • Resolution set to wontfix
  • Summary changed from Copy/Paste between Linux Host and Windows XP Guest not fully working to Select and middle-click paste in X11 not supported -> won't fix

Closing this as there are no immediate plans to implement middle-click cut and paste

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use