VirtualBox

Ticket #7803 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

Heavy I/O causing Windows 2008 guest freeze on Ubuntu Host

Reported by: smartinez Owned by:
Priority: critical Component: other
Version: VirtualBox 3.2.12 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

We are currently running a Windows 2008 64-bit server on a Ubuntu 64-bit Host (Kernel v2.6.32.26.11-lucid). The host is set up with 8 GB of RAM and 2 Intel Xeon Quad core processors. Hardware virtualization is enabled in the BIOS.

The "freeze" seems to happen when there is heavy I/O activity on the virtual machine (e.g. disk backups). The machine becomes completely unresponsive and there is no indication of any disk activity. Also, any attempts to ping the machine are unsuccessful. We are forced to shut down the machine using the red-x.

It might be worth mentioning that in addition to the Windows 2008 machine, we have 4 Linux CentOS guests that are currently running without any problems. Previously, three of the linux guests had filesystems that would become corrupt and go into "read-only" mode at about the same time the Windows machine would freeze. However, this is no longer happening with the current Ubuntu kernel we are running (we have tried multiple kernels in hope of fixing the issue; so far the kernel we are on seems to be the best). The linux machines are running as CLI only.

I'm attaching the windows machine configuration xml as well as the VBox log file with this ticket.

Thank you in advance for your help with this.

Attachments

Primary.xml Download (10.9 KB) - added by smartinez 3 years ago.
VBox.log.1 Download (115.0 KB) - added by smartinez 3 years ago.
Primary.2.xml Download (10.9 KB) - added by smartinez 3 years ago.
VBox.log.2.1 Download (209.6 KB) - added by smartinez 3 years ago.

Change History

Changed 3 years ago by smartinez

Changed 3 years ago by smartinez

comment:1 Changed 3 years ago by aeichner

Can you try to lower the CPU count of the guest to 1? We have a similar bug report iirc (I'm unable to find it at the moment) and lowering the CPU count fixed the hang.

comment:2 Changed 3 years ago by ninthclowd

Hi I work with smartinez on this server. We have tried single processor and the box runs so slow that it's unusable (event viewer takes almost a minute to open), however that was back when it was a 32-bit guest and may have been the result of bug #4392. So I'll change it tonight and see.

At one point we thought it was network activity from folder replication that caused the freeze so we install the virtio drivers, but I now am quite positive its the i/o from the folder replication. The host is running a fairly large raid 5 array (5TB) on a 3ware controller so i/o times are a bit slower between all of the VMs... not sure if that's related or not. I've tried both IDE and SATA controllers, and with and without I/O cache on the host.

All I know is the problem seemed to get much worse with different kernels (especially 2.6.36)

comment:3 Changed 3 years ago by smartinez

Well we changed the guest vm to use a single processor back on 12-07-10 and so far we haven't had any more freezes.

However, the overall usability of the server has declined considerably. At times it takes several minutes to open up a single application (e.g. event viewer). The CPU usage is constantly between 25-50% when idle. Being that this is one of our main production servers, it would be a huge benefit if we could have the "responsive" machine we had when using the multiple processors.

Looking at some of the other bugs out there, it looks like this is an issue with the intensive disk i/o and the multiple processors. Is there any sort of idea as to when this might be fixed?

comment:4 Changed 3 years ago by hanasaki

Seeing the same issue as of 3.2.10 and 3.2.12 Fedora 10 host 32bit - Ubuntu 10.10 guest 32bit

comment:5 Changed 3 years ago by smartinez

Dropping the CPU count to 1 didn't fix the problem. we're still having freezes on the guest. I'm attaching our current machine config xml and the vbox log files.

Changed 3 years ago by smartinez

Changed 3 years ago by smartinez

comment:6 Changed 3 years ago by sergiomacedo

smartinez/ninthclowd, could you specify your least troublesome kernel version?

Recently I was hit with a similar problem (almost lost a linux guest FS) though I was able to work around it with HostIOCache. I found your information about different kernel versions having different results regarding IO load very interesting.

Thanks for your attention.

comment:7 Changed 3 years ago by ninthclowd

Our most stable kernel is the one we're using now:

Linux 2.6.32-0206322611-generic #201011240908 SMP Wed Nov 24 09:11:08 UTC 2010 x86_64 GNU/Linux

comment:8 Changed 3 years ago by frank

Still reproducible with VBox 4.0.6?

comment:9 Changed 3 years ago by ninthclowd

Sorry for not updating this sooner. No, this problem seemed to fixed since upgrading to version 4. What's more SMP is working well! So ya, you guys are awesome and can close this bug.

comment:10 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Thanks for the update.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use