VirtualBox

Ticket #780 (closed defect: fixed)

Opened 7 years ago

Last modified 6 years ago

Bidirecional Shared Clipboard 1.5.51

Reported by: nagaozen Owned by:
Priority: major Component: other
Version: VirtualBox 1.5.0 Keywords: Clipboard 1.5.51 RDC Bridge
Cc: Guest type: other
Host type: other

Description

First of all, THANKS A LOT FOR THIS PIECE OF GOLD!

Well, I've compiled the 1.5.51 from the trunk 'cause I belived that the bugs of 1.5.0 was already fixed. I'm using a Ubuntu 7.04 with a i386-server-kernel and the problems with the 1.5.0 was:

B-1. Shared Clipboard not working between host (Ubuntu 7.04) and guest (Windows 2003) when guest is working Remote Desktop Connection.

B-2. " and ' not working on the guest

As we can see in the forum, both problems should be fixed in 1.5.2. Bug B-2 is OK, but for my surprise B-1 was only partial solved. I still get ŸŸ in some cases. To reproduce the error follow these steps:

  1. Open a text editor in host and write: "The quick brown fox jumps over the lazy dog - HOST."
  1. Copy it to the clipboard.
  1. Open a text editor in the guest and paste the Clipboard content. (The text should be fine)
    1. Open a RDC in the guest and in the RDC Client open a text editor and paste the Clipboard content. This should appear: "ŸŸquick brown fox jumps over the lazy dog - HOST."
      1. Paste again the Clipboard in the guest text editor and you still have the: "ŸŸquick brown fox jumps over the lazy dog - HOST." in the Clipboard, well it still here in the host, since I'm pasting here xP

Other combinations using this environment (Host, Guest, RDC in the Guest), like copying in the RDC and pasting in host gives similar errors.

One more thing: B-3. The bridge i'd working in 1.5.0 built as described in the UsersManual.pdf is no longer working with the 1.5.51, but NAT is ok.

Hope it helps you to keep doing this amazing job and, again, THANK YOU A LOT!

Change History

comment:1 follow-up: ↓ 3 Changed 7 years ago by michael

Re the bridge problem, are your VirtualBox networking scripts still set up correctly with version 1.5.51?

comment:2 follow-up: ↓ 4 Changed 7 years ago by michael

Re the clipboard problem, the fixes in 1.5.51 require you to update the Guest Additions. As this is a bit tricky to do for Windows guests, you may prefer to wait until 1.5.2 is released (no date yet, but it should be quite soon).

comment:3 in reply to: ↑ 1 Changed 7 years ago by nagaozen

Replying to michael:

Re the bridge problem, are your VirtualBox networking scripts still set up correctly with version 1.5.51?

Yes, even if I set everything like in 1.5.0: Host Interface, tap0 it doesn't work.

comment:4 in reply to: ↑ 2 Changed 7 years ago by nagaozen

Replying to michael:

Re the clipboard problem, the fixes in 1.5.51 require you to update the Guest Additions. As this is a bit tricky to do for Windows guests, you may prefer to wait until 1.5.2 is released (no date yet, but it should be quite soon).

Hm... I want to try it, how should I proceed ?

comment:5 Changed 7 years ago by michael

Re networking, 1.5.0 is a release, and installs init scripts which take care of the network setup. 1.5.51 is not a release, and you have to do this yourself. I would really recommend that you wait another week or two until 1.5.2 hits the website and retry (reinstalling the guest additions using 1.5.2).

comment:6 Changed 6 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed

Try again with 1.6.0 and report back if it's still relevant. Thanks.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use