VirtualBox

Ticket #7737 (closed defect: duplicate)

Opened 3 years ago

Last modified 3 years ago

SATA disks not found after reboot into linux

Reported by: mmusterd Owned by:
Priority: major Component: other
Version: VirtualBox 3.2.10 Keywords:
Cc: Guest type: Linux
Host type: Windows

Description

Situation:

  • I have a IDE hdd with a linux installation on it, as well as grub.
  • I have a IDE cdrom with an image of windows XP on it.
  • I have a SATA hdd with windows XP on it, or nothing

I want to boot the linux OS, which will determine if the windows XP partition is available and has booted correctly. If this is the case, a grub-reboot is issued to boot into windows XP once, otherwise the image is restored onto the HDD. If I reboot from windows XP, the linux OS should do the above again.

On an actual machine, the procedure works without a hitch.

However after a reboot from windows XP to linux (Start | Shut Down... | Restart) the linux suddenly can't find the SATA disks.

dmesg has the following lines: [ 6.166426] ata1.00: qc timeout (cmd 0xec) [ 6.166426] ata1.00: failed to IDENTIFY (I/O error, err_mask=0x4) [ 6.516437] ata1: SATA link up 3.0 Gbps (SStatus 123 SControl 300) [ 16.517619] ata1.00: qc timeout (cmd 0xec) [ 16.517619] ata1.00: failed to IDENTIFY (I/O error, err_mask=0x4) [ 16.517619] ata1: limiting SATA link speed to 1.5 Gbps [ 16.866406] ata1: SATA link up 1.5 Gbps (SStatus 113 SControl 310) [ 46.866424] ata1.00: qc timeout (cmd 0xec) [ 46.866424] ata1.00: failed to IDENTIFY (I/O error, err_mask=0x4) [ 47.216399] ata1: SATA link up 1.5 Gbps (SStatus 113 SControl 310) [ 47.566424] ata2: SATA link up 3.0 Gbps (SStatus 123 SControl 300) [ 52.566425] ata2.00: qc timeout (cmd 0xec) [ 52.566425] ata2.00: failed to IDENTIFY (I/O error, err_mask=0x4) [ 52.916425] ata2: SATA link up 3.0 Gbps (SStatus 123 SControl 300) [ 62.916398] ata2.00: qc timeout (cmd 0xec) [ 62.916398] ata2.00: failed to IDENTIFY (I/O error, err_mask=0x4) [ 62.916398] ata2: limiting SATA link speed to 1.5 Gbps [ 63.266424] ata2: SATA link up 1.5 Gbps (SStatus 113 SControl 310) [ 93.266437] ata2.00: qc timeout (cmd 0xec) [ 93.266437] ata2.00: failed to IDENTIFY (I/O error, err_mask=0x4) [ 93.616439] ata2: SATA link up 1.5 Gbps (SStatus 113 SControl 310)

Attached is the full vbox.log and the full dmesg as I have it.

Change History

comment:1 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use