VirtualBox

Ticket #7716 (new defect)

Opened 3 years ago

Last modified 9 months ago

virtualbox prevents linux host from suspending/hibernating

Reported by: matteosistisette Owned by:
Priority: critical Component: host support
Version: VirtualBox 3.2.10 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description (last modified by michael) (diff)

I'm running a Windows Vista 64bit guest on an Ubuntu 10.04 32bit host.

When the guest is running:

  • if I try to _suspend_ Ubuntu, it hangs forever and never completes suspending. But i cannot resume either. I am forced to power off the computer by holding the power button.
  • If I try to _hibernate_ the host, it fails too. Sometimes it just locks screen instead of hibernating, so I can "resume" by entering the password. Other times it hangs and doesn't complete the hibernation process but cannot resume either so I'm forced to power it off as in the suspend case, and when I power it on again, it boots from scratch.

When Virtual Box is not running, host suspends/hibernates and resumes properly.

I've always had this problem since I have Virtual Box, which is months, but only now I've realised it always and only happens when Virtual Box is running.

I'm not sure whether I should classify this as "blocker" or "critical". This can cause disastrous data loss not only on the guest but also on the host. Even assuming you can live without suspending/hibernating and that you won't do it without thinking, this means you can never leave a laptop unattended powered by battery.

Attachments

VBox.log Download (54.0 KB) - added by matteosistisette 3 years ago.
XP1-2011-03-24-00-10-17.log Download (79.9 KB) - added by davidsarah 3 years ago.
VBox.log
VBox.2.log Download (54.4 KB) - added by phord 9 months ago.
VBox.log of Windows 7 guest startup
syslog Download (35.3 KB) - added by phord 9 months ago.
var/log/syslog around the time of the hang

Change History

comment:1 Changed 3 years ago by frank

I run 32-bit guests and 64-bit guests with and without VT-x on a 64-bit Ubuntu Maverick host and suspending + resuming the host worked without any problems.

Please attach a VBox.log file of a session which runs when you _would_ suspend the host. Do not really suspend the host but attach the VBox.log file here which will show me your VM configuration.

Changed 3 years ago by matteosistisette

comment:2 Changed 3 years ago by matteosistisette

here it is.

I've now realised that even _after_ closing VirtualBox, suspending or hibernating still fail. However, when I restart the host and don't run VirtualBox, then suspending and hibernating work.

May this indicate the issue is related to vb's kernel module? Is the module only loaded when virtualbox is started? Is it not "unloaded" (not sure this is the correct word) when vb is closed?

I can't be 100% sure the problem is actually related to VB. It may only be a coincidence. But since I've started paying attention to it, every time suspend/hibernate has failed, I had run VB during the same session on the host (i.e. since the last reboot).

comment:3 follow-up: ↓ 5 Changed 3 years ago by davidsarah

I have almost identical symptoms to this report (with a 64-bit Ubuntu 10.10 host and 32-bit Windows XP guest). The guest additions are installed in the guest, and dkms is installed in the host.

When a guest instance is running, the Ubuntu shutdown/hiberate menu does not open (clicking the icon has no effect). With the guest paused, it opens but selecting 'Hibernate' only causes the screen to be locked. I haven't yet tried closing VB and then hibernating.

Attaching the VBox.log. (The guest is paused. There were attempts to hibernate after each "Changing the VM state from 'SUSPENDING' to 'SUSPENDED'" line.)

Changed 3 years ago by davidsarah

VBox.log

comment:4 Changed 3 years ago by davidsarah

Another report of this problem:  http://ubuntuforums.org/showthread.php?t=1445109

comment:5 in reply to: ↑ 3 Changed 3 years ago by davidsarah

Replying to davidsarah:

I haven't yet tried closing VB and then hibernating.

Just tried that now -- a hibernate and resume were successful after closing VB.

comment:6 Changed 3 years ago by SCAI_Andre

Same problem here: VirtualBox 4.0.4 64Bit on Ubuntu 10.10 64 Bit

When once a VM was up suspend to disc does not work any more. Stand By works well.

Suspend to disc worked always before, also with VmWare Server 2.0.2 VMs started.

comment:7 Changed 3 years ago by matteosistisette

Now with Virtual Box 4 and Ubuntu 10.10 host, I can't hibernate the host if Virtual Box is running.

Since I've upgraded Ubuntu to 10.10, hibernate/suspend issues unrelated to Virtualbox have disappeared. Now hibernation always work if I'm not running virtual box, However, when I am running virtualbox, hibernation on the host systematically fails. Haven't tried suspend.

comment:8 Changed 2 years ago by jimav

Confirming that client hibernate has never worked for Ubuntu clients (with Ubuntu host in my case).

I just re-tested using vb 4.1.12. Client is Ubuntu 11.10 32-bit, with updated guest additions and PAE/NX enabled. Host is Ubuntu 64-bit (i7 CPU).

When hibernating the client, an error window says "A critical error has occurred while running the virtual machine and the machine execution has been stopped" etc.

VBox.log will be uploaded if possible (but currently I don't see any way to do that...)

comment:9 Changed 2 years ago by michael

  • Description modified (diff)

The attach button is near the top of the ticket page, not at the bottom.

comment:10 Changed 2 years ago by michael

Not relevant, I didn't see ticket #10475 immediately.

Changed 9 months ago by phord

VBox.log of Windows 7 guest startup

Changed 9 months ago by phord

var/log/syslog around the time of the hang

comment:11 Changed 9 months ago by phord

This problem still occurs on Ubuntu 13.04 and VirtualBox 4.2.10. I run Windows 64-bit Guest. If I close VirtualBox first, I can suspend or hibernate Ubuntu reliably. If I leave VirtualBox open, Ubuntu usually "hangs" during hibernate/suspend attempt with the system still powered.

I uploaded my syslog and VBox.log (VBox.2.log) around the time of the most recent failure. After the failed suspend, my video was toast (all grey). Ctrl-Alt-F2 (switch to console 2) did not work. But, curiously, Fn+Radio worked to disable and enable my wireless radio. You can see the events in my syslog:

Aug  5 16:11:30 ipsn-lnx-hordp NetworkManager[1222]: <info> WiFi now disabled by radio killswitch
Aug  5 16:11:30 ipsn-lnx-hordp NetworkManager[1222]: <info> (wlan0): device state change: need-auth -> unavailable (reason 'none') [60 20 0]
Aug  5 16:11:30 ipsn-lnx-hordp NetworkManager[1222]: <info> (wlan0): deactivating device (reason 'none') [0]
Aug  5 16:11:34 ipsn-lnx-hordp NetworkManager[1222]: <info> WiFi now enabled by radio killswitch

I tried this specifically because I can see the results on the WiFi light on my laptop.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use