VirtualBox

Ticket #7699 (closed defect: obsolete)

Opened 3 years ago

Last modified 2 months ago

driver-related OpenGL segfaults

Reported by: eteq Owned by:
Priority: major Component: 3D support
Version: VirtualBox 3.2.10 Keywords:
Cc: Guest type: Linux
Host type: Windows

Description (last modified by misha) (diff)

In Ubuntu 10.10 64 (although I'm fairly sure someone on the forums saw the same in 10.04) and Windows 7 64bit, with guest additions installed, many programs using OpenGL (definitely all that use GLUT, and some others) segfault. Some still work (e.g. compiz, glxgears), so I know the 3D drivers are enabled.

Looking at a few backtraces in Ubuntu, the commonality they seem to share is that they crash in the driver code where they are trying to get information about what OpenGL extensions or windows are available. Let me know what other debug info might be needed.

(VBox.log is attached)

Attachments

VBox.log Download (56.9 KB) - added by eteq 3 years ago.

Change History

Changed 3 years ago by eteq

comment:1 Changed 3 years ago by porst17

Is there any hope for a bugfix? I still have the same issue with VirtualBox 4.0.10 and Ubuntu 11.04.

comment:2 Changed 6 months ago by misha

  • Description modified (diff)

Could you check whether the issue is fixed with VBox 4.3 and 4.3 Additions, and if not - provide a fresh VM log file please?

comment:3 Changed 2 months ago by frank

  • Status changed from new to closed
  • Resolution set to obsolete
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use