VirtualBox

Ticket #7687 (closed defect: duplicate)

Opened 3 years ago

Last modified 3 years ago

save/restore state after restart does not work (regression 3.2.10)

Reported by: mrzephy Owned by:
Priority: critical Component: GUI
Version: VirtualBox 3.2.10 Keywords: save restore state
Cc: Guest type: Linux
Host type: Windows

Description

Tested with Windows host, Ubuntu guest (also tried OSX guest, same problem). Tested on two different computers, one with totally clean install, all experience this. 3.2.8 does not experience this bug. When uninstalling 3.2.10 and reinstalling 3.2.8, this bug goes away.

To reproduce:

  • close an open Ubuntu VM (e.g. showing Ubuntu desktop) and choose "Save the machine state"
  • close VirtualBox entierly (very important step)
  • open VirtualBox
  • restore the Ubuntu VM

A white window will appear in the top-left corner of the screen. The only way to make the VM work again is to attempt to resize this window, closing it, choose Power off and restart the Ubuntu VM completely.

I have not been able to reproduce this bug every time, it seems to only happen some times, especially the first time after installing VirtualBox and saving a Ubuntu VM session for the first time. It doesn't seem to matter if the Ubuntu VM was created with 3.2.10 (it can be from a previous version, it doesn't seem to matter). System reboot might also help to trigger this? Not sure. Especially it should happen if done right after installing 3.2.10.

Change History

comment:1 Changed 3 years ago by mrzephy

Also noticed Ubuntu does not detect the network connection anymore after a state restore.

comment:2 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Looks like a duplicate of #7159.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use