VirtualBox

Ticket #7662 (closed enhancement: duplicate)

Opened 3 years ago

Last modified 3 years ago

VBoxManage clonehd should write the destination filename with full path

Reported by: raffen Owned by:
Priority: minor Component: VM control
Version: VirtualBox 3.1.8 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

I would expect the

sudo VBoxManage clonehd bar.vdi foo.vdi

command to write to the current directory as the destination file foo.vdi is not given full path. The actual result is that the destination file is written to

/root/.VirtualBox/HardDisks/

Suggested solution:

VBoxManage clonehd should write the destination filename with full path to stdout, e.g.

< Clone hard disk created in format 'VDI'.  
--
> Clone hard disk '/root/.VirtualBox/HardDisks/foo.vdi' created in format 'VDI'.  

Example:

$ pwd
/data/virtualbox/harddisks

$ sudo VBoxManage clonehd bar.vdi foo.vdi
[sudo] password for foo: 
Sun VirtualBox Command Line Management Interface Version 3.1.8
(C) 2005-2010 Sun Microsystems, Inc.
All rights reserved.

0%...10%...20%...30%...40%...50%...60%...70%...80%...90%...100%
Clone hard disk created in format 'VDI'. UUID: 07dc6716-7038-4518-80a7-90113e6595c8

$ ls | grep foo
$

$ VBoxManage -v
3.1.8r61349
$ uname -a
Linux desktop 2.6.18-194.8.1.el5 #1 SMP Thu Jul 1 19:04:48 EDT 2010 x86_64 x86_64 x86_64 GNU/Linux

Change History

comment:1 Changed 3 years ago by klaus

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #3552

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use