VirtualBox

Ticket #7655 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

VM and system hangs when NetFilter enabled

Reported by: Demontager Owned by:
Priority: critical Component: network/hostif
Version: VirtualBox 3.2.8 Keywords: Net Filter
Cc: Guest type: Windows
Host type: Linux

Description

I got big problem with VB when Netfilter enabled in Kernel ( I need Net Filter because I use iptables to share Internet to others PCs). I'm sure this happens when Net Filter enabled because when not, VB works ok. And the problem is- When I start any VMs all system hangs completely. Is it Kernel bug ? Is Any methods to solve it, except disabling net filter ? Kernel config -  http://pastebin.com/a9EG5ePG

Attachments

VBox.log.2 Download (73.9 KB) - added by Demontager 3 years ago.

Change History

Changed 3 years ago by Demontager

comment:1 Changed 3 years ago by frank

The netfilter cannot be the criteria because it works fine here with netfilter enabled. When does the host crash happen, immediately after starting the VM or later? And is there any chance that you can post the content of the kernel crash?

comment:2 Changed 3 years ago by Demontager

This crash happens when I start any Virtual Machine. Now I fully isolated this bug, if Bridged adapter enabled in VMs settings this cause hangs. And when NAT, everything ok, VM loaded and no issues. Will try to get more info from dmesg /etc/var/log/messages as well. Also just a little I edited kernel config for netfilter and set his feuters loaded solid to kernel(before as modules), but don't think it interfere to much on this issue.  http://pastebin.com/q833MLEP

comment:3 Changed 3 years ago by frank

  • Component changed from other to network/hostif

Ok, so no NAT problem. To be sure: You expect a VM and host hang if you start a VM with bridged network enabled regardless of the netfilter setting in your Linux kernel, correct? Or do you still experience these hangs only if netfilter is enabled?

comment:4 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

No response, closing. Before consider to reopen this ticket please try the current version (4.0.4) and provide the information I've asked for.

comment:5 Changed 3 years ago by Demontager

Sorry for not replying, i was out of Internet long time. See, it very hard to trace this issue now since i changed kernel to 2.6.36-gentoo. Anyway it happens sometimes only very rarely, before always. Hope it was kernel issue. If i will notice this issue after VB update i will let you know.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use