VirtualBox

Ticket #7644 (closed defect: worksforme)

Opened 4 years ago

Last modified 3 years ago

VirtualBox 3.2.10 fails to start

Reported by: VADR Owned by:
Priority: major Component: other
Version: VirtualBox 3.2.10 Keywords:
Cc: adiev@… Guest type: other
Host type: Linux

Description

Trying to execute VirtualBox results in the following error: $ VirtualBox VirtualBox: supR3HardenedMainGetTrustedMain: dlopen("/usr/lib/virtualbox/VirtualBox.so",) failed: /usr/lib/libQtOpenGL.so.4: undefined symbol: _ZNK7QPixmap9isQBitmapEv

Host: Fedora 13 i386: $ uname -r 2.6.34.7-61.fc13.i686

VirtualBox version: 3.2.10r66523, installed as update of previous version from virtualbox repository. Downgrade to version 3.2.8 does not solve the problem.

Attachments

yum_provides_libQtOpenGL Download (630 bytes) - added by VADR 4 years ago.
yum provides libQtOpenGL.so.4
yum_info_qt-x11 Download (571 bytes) - added by VADR 4 years ago.
yum info qt-x11
attach3.txt Download (75 bytes) - added by VADR 3 years ago.
rpm -qal qt-x11\*|grep libQtGui.so.4

Change History

Changed 4 years ago by VADR

yum provides libQtOpenGL.so.4

Changed 4 years ago by VADR

yum info qt-x11

comment:1 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #7623.

comment:2 Changed 3 years ago by VADR

  • Status changed from closed to reopened
  • Resolution duplicate deleted

No, this is not a duplicate. As root VirtualBox can't be started too.

comment:3 Changed 3 years ago by frank

Which VirtualBox package did you install (exact package name please)?

comment:4 Changed 3 years ago by VADR

$ yum info virtualbox-3.2 ..... Name : VirtualBox-3.2 Arch : i686 Version : 3.2.10_66523_fedora13 Release : 1 Size : 91 M Repository : installed From repo : virtualbox

comment:5 Changed 3 years ago by frank

Sorry but this package installs and works very well here on a Fedora 13 installation. And the missing symbol _ZNK7QPixmap9isQBitmapEv is provided by /usr/lib/libQtGui.so.4.6.3 which is part of qt-x11 as well. So it looks like your installations is somehow screwed up. You might want to re-install qt-x11.

comment:6 Changed 3 years ago by VADR

The error message says ".../usr/lib/libQtOpenGL.so.4: undefined symbol: _ZNK7QPixmap9isQBitmapEv...", not "/usr/lib/libQtGui.so.4.6.3".

I tried to reinstall qt-x11, error message is changed: "VirtualBox: supR3HardenedMainGetTrustedMain: dlopen("/usr/lib/virtualbox/VirtualBox.so",) failed: /usr/lib/libQtOpenGL.so.4: undefined symbol: _ZN14QWidgetPrivate15checkWindowRoleEv", but VirtualBox still does not work.

comment:7 Changed 3 years ago by frank

I know what the error messages says but I also know where the symbol comes from (checked locally). The symbol _ZN14QWidgetPrivate15checkWindowRoleE comes from /usr/lib/libQtGui.so.4.6.3 as well. Are you 100% sure that your Linux installation is up-to-date and that you don't have any private packages (except VirtualBox) installed? Could you attach the compressed output of

rpm -qal qt-x11\*|grep libQtGui.so.4

to this ticket?

Changed 3 years ago by VADR

rpm -qal qt-x11\*|grep libQtGui.so.4

comment:8 Changed 3 years ago by VADR

I solved the problem. In my system installed software for hardware key eToken NG ( http://www.aladdin-rd.ru/en/). This software installed it's own copies of Qt-libraries in directory /usr/lib/eToken/: libQtCore.so.4.2.3, libQtGui.so.4.2.3, libQtXml.so.4.2.3, and symlinks in the same directory: libQtCore.so.4, libQtGui.so.4, libQtXml.so.4. I removed symlinks, after system restart VirtialBox is working.

Ticket can to be closed. Thanks.

comment:9 Changed 3 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to worksforme
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use