VirtualBox

Ticket #764 (closed defect: fixed)

Opened 7 years ago

Last modified 5 years ago

Guest window cannot be re-size after remote desktop connection to host

Reported by: dsierra Owned by:
Priority: minor Component: GUI
Version: VirtualBox 1.5.0 Keywords:
Cc: Guest type: other
Host type: Windows

Description

The result is the same as the one depicted in defect #516, except that is caused by a remote desktop connection.

Host = Guest = WinXP

Guest is running, then I use remote desktop to connect to host, host resolution does not change, but guest window shows the two scroll bars as in picture  http://www.virtualbox.org/attachment/ticket/516/2.PNG of ticket #516. Neither Host+A nor Host+G solves anything. The only solution is to stop (saving state is OK) and start guest again.

Attachments

1_before-iconize.PNG Download (76.2 KB) - added by dsierra 7 years ago.
1 .- Initial setup. Remote desktop to host, then iconize vbox and logout
2_after-restore.PNG Download (76.2 KB) - added by dsierra 7 years ago.
2.- New remote desktop to host and restore vbox guest window
3_after-Host+G.PNG Download (76.1 KB) - added by dsierra 7 years ago.
after Host+G
4_after-Host+A.PNG Download (68.1 KB) - added by dsierra 7 years ago.
later, after Host+A
5_after-setguestsize800x600.PNG Download (60.3 KB) - added by dsierra 7 years ago.
after guest screen configuration to 800x600

Change History

comment:1 follow-up: ↓ 2 Changed 7 years ago by dsierra

Well, the guest window CAN be resized, but the scroll bars will stay there, just like the two empty spaces on the lateral sides.

comment:2 in reply to: ↑ 1 Changed 7 years ago by sunlover

Please provide a bit more information.

1) You said you connect to the host. Does "remote desktop connection" connect to the VirtualBox VRDP server or to the XP host RDP server?

2) Do you have the guest additions installed?

comment:3 Changed 7 years ago by dsierra

Sorry.

1) Remote desktop connection connects to the XP host RDP server.

2) Yes, guest additions are installed on guest.

I will try to post a picture.

Changed 7 years ago by dsierra

1 .- Initial setup. Remote desktop to host, then iconize vbox and logout

Changed 7 years ago by dsierra

2.- New remote desktop to host and restore vbox guest window

comment:4 follow-up: ↓ 5 Changed 7 years ago by dsierra

Well, now I know exactly when it happens.

1.- I use remote desktop connection to connect from local PC to host PC.

2.- I started vbox guest (see attachment 1) in remote host PC.

Resizing guest works as expected.

3.- I leave vbox guest window iconized and logout from remote desktop.

4.- Again, remote desktop connection to host.

5.- I restore vbox guest window (see attachment 2) in remote host PC.

vbox guest screen looks weird now.

6.- You can see the effect of pressing Host+G (attach. # 3) and later Host+A (attach. # 4).

7.- Changing vbox guest screen size to 800x600 gives attach. # 5.

Screen resolutions of pictures:

                    Local PC: 1280x1024
                 Remote Host: 1280x1024
   VBox Guest in remote host:  800x600

(vbox guest window was never manually moved)

Changed 7 years ago by dsierra

after Host+G

Changed 7 years ago by dsierra

later, after Host+A

Changed 7 years ago by dsierra

after guest screen configuration to 800x600

comment:5 in reply to: ↑ 4 Changed 6 years ago by dsierra

Hi!

Now, with Vbox & Guest additions 1.5.2 the problem seems to be solved (or at least I cannot reproduce it as I explained :-)

Thanks for your work.

comment:6 Changed 6 years ago by frank

  • Host type changed from other to Windows

comment:7 Changed 6 years ago by frank

  • Component changed from other to GUI

comment:8 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use