VirtualBox

Ticket #7635 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

bad sound quality guest W7PRO x64

Reported by: ilozenfants@… Owned by:
Priority: major Component: audio
Version: VirtualBox 3.2.10 Keywords: Audio W7 x64 bad sound
Cc: Guest type: Windows
Host type: Windows

Description

My host is HP Quad core with VISTA SP1 4 Go ram

VBOX v3.2.8 Audio : AC97 enable

1°) test a windows 7 Pro x86 guest : windows update install de AC97 audio device driver. It's work fine

2°) test a windows 7 Pro x64 guest : windows update does not detect the AC97 audio device. I download and install the last Realtek AC97 drivers for W7 x64 from realtek web site. It's work but the sound quality is very very bad.

3°) Upgrade VBOX v3.2.8 to v3.2.10 : same problem on my W7PRO x64 guest

4°) Tests with Audio Soundblaster 16 : not detected by W7 (sound card too old?)

5°) Test the W7 x64 guest on another host with VBOX 3.2.10 : same problem

6°) search for any solution on your site and microsoft web site : no solution

Question : What can i Do ? Did you add soon another emulated sound card on VBOX future versions ? Is there a fix (Vbox fix ou Microsoft W7 x64 fix) for this problem ?

I had another guest in Win XP SP3 that work fine for months and no problem for sound with this guest so the problem is not a hardware problem

Change History

comment:1 follow-up: ↓ 2 Changed 3 years ago by Hachiman

Does it changed for you in VBox 4.0.0 with HDA/stac9220 emulation?

comment:2 in reply to: ↑ 1 Changed 3 years ago by ilozenfants@…

Replying to Hachiman:

Does it changed for you in VBox 4.0.0 with HDA/stac9220 emulation?

Hello, same problem with Intel HD Audio Driver and HardWare PIIX3 emulation The sound seems to be better, but not good at all, it stutter sometimes

I tried with ICH9 Hardware Emulation and it is worse : the sound stutter and Windows media player completely freeze after a few seconds !

comment:3 Changed 3 years ago by Hachiman

Could you please add Log file for HDA/PIIX3 and HDA/ICH9 configurations?

comment:4 Changed 3 years ago by frank

  • Priority changed from critical to major

comment:5 Changed 3 years ago by ilozenfants@…

Virtual Box Updated to version 4.0.4 and all works fine in my HP Quad core with VISTA SP1 4 Go ram with Intel HD Audio emulation !!

Thanks !

comment:6 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Thanks for the feedback!

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use