VirtualBox

Ticket #7615 (closed defect: obsolete)

Opened 3 years ago

Last modified 4 months ago

HIGH CPU usage (between ~30/60)

Reported by: xok Owned by:
Priority: minor Component: other
Version: VirtualBox 3.2.10 Keywords: high cpu, cpu, cpu usage
Cc: Guest type: Linux
Host type: Windows

Description (last modified by frank) (diff)

Hello,

I have installed the lastest version (3.2.10) and it does a lot of HIGH CPU usage.

See images attached.

Attachments

task_manager.PNG Download (81.6 KB) - added by xok 3 years ago.
HOST - Task Manager
top.PNG Download (64.1 KB) - added by xok 3 years ago.
GUEST - top
centos_svn_trac-2010-10-19-14-42-02.log Download (74.5 KB) - added by xok 3 years ago.
centos_svn_trac-2010-10-19-14-46-39.log Download (74.4 KB) - added by xok 3 years ago.
centos_svn_trac-2010-10-19-19-31-19.log Download (83.8 KB) - added by xok 3 years ago.
centos_svn_trac-2010-10-20-11-50-30.log Download (39.2 KB) - added by xok 3 years ago.
DxDiag.txt Download (44.5 KB) - added by xok 3 years ago.
DXDIAG
proc_explorer.PNG Download (115.3 KB) - added by xok 3 years ago.
proc_explorer_threads.PNG Download (68.2 KB) - added by xok 3 years ago.
boot.PNG Download (111.6 KB) - added by xok 3 years ago.

Change History

Changed 3 years ago by xok

HOST - Task Manager

Changed 3 years ago by xok

GUEST - top

Changed 3 years ago by xok

Changed 3 years ago by xok

Changed 3 years ago by xok

Changed 3 years ago by xok

Changed 3 years ago by xok

DXDIAG

comment:1 Changed 3 years ago by sandervl73

  • Priority changed from critical to major

Not very useful. What are you doing inside the guest?

comment:2 Changed 3 years ago by xok

Absolutely nothing!

Standard CentOS 5.5 clean installation, 99.7% IDLE ... and consuming ~30/60 CPU usage on the host (VirtualBox.exe).

I can provide you the Virtual Machine file that I am using if you want.

comment:3 Changed 3 years ago by sandervl73

You have of course looked at the manual before opening this ticket, right? ( http://www.virtualbox.org/manual/ch12.html#id492241)

comment:4 Changed 3 years ago by xok

I dont think it is about what you are pretending to say..

I have attached more images:

  • Image of boot loader (already consuming a lot of CPU, without the OS loaded)
  • Image of Process Explorer - VirtualBox.exe consuming 45% avg.

Changed 3 years ago by xok

Changed 3 years ago by xok

comment:5 Changed 3 years ago by xok

I have not expressed very well.

The CPU usage in the image "proc_explorer.PNG", is when we are booting see image "boot.PNG"

Changed 3 years ago by xok

comment:6 Changed 3 years ago by sandervl73

Did you or did you not change the kernel timer frequency of the CentOS guest? If you didn't do what the link describes, then it's not a bug.

comment:7 Changed 3 years ago by xok

Yes, I have added the divider=10 instruction on the GRUB.

But if the OS is still not loaded, what difference does that instruction make? It is on the boot screen, see image "boot.PNG". IMHO, it should not be doing that amount of CPU usage.. I guess..

The prior version 3.2.8 seems "better" relating to this issue as this was not very noticed.

comment:8 Changed 3 years ago by sandervl73

  • Priority changed from major to minor

The high cpu load at the GRUB prompt is not relevant unless you like to look at it the whole day. Most boot loaders just spin and waste cpu cycles. I doubt that was any different with 3.2.8.

So the high cpu usage in an otherwise idle CentOS guest was solved with the divider=10 option?

comment:9 Changed 3 years ago by xok

Nope.

Adding divider=10 does the same CPU usage..

This version also closes randomly the GUI.

In the installation, the VirtualBox Host Adapter in some circunstances, which I didnt figure out yet, sometimes has a conflict with an "3G Adapter" GlobeTrotter HPxPA, sometimes with the SmartCard Reader Gemalto PC Twin (USB) and it does not appear.

The 3.2.8 is a lot more stable than this version 3.2.10, I have reinstalled this versions about 4 or 5 times so that the hardware is properly detected.

I give another shot trying to recompile the kernel.. Well .. I am trying to understand what it means and what it does.. :) LOL

After that I will revert to 3.2.8 as in my case it is the better thing to do.

comment:10 follow-up: ↓ 11 Changed 3 years ago by Roomer

I am running into the same problem with VirtualBox 2.6.10 and CentOS 5.4. (same problem seems to appear with 3.2.8 version too)

Unfortunately its business-critital in my case since we use CentOS as default OS. I really hope there is a solution for this Problem.

In my case the CPU Usage goes up to 100%. If i use the divider=10 its at least down to 20 during the VM is in idle state. Its up to 100 if the VM boots (which takes about 5 times as long as it should)

following tests were made with version 2.6.10 on the following OS: latest Max OS 10.x (latest updates), Debian Lenny 2.6.26, Ubuntu 10.10 (2.6.35), Gentoo (2.6.34). Used the same VM image (exported it to OVF and reimported it then).

combinations of kernel parameters tested: divider=10, noapic, nolapic, acpi=off, clocksource=acpi corresponding to the VM setting (apic enabled/disabled)

Its worst on the Ubuntu Host. There i have 100% CPU and additionally a load of 1.5.

Than testing all of the parameters again with the special VM-kernel that CentOS offers in testing repository.

I found an advice that you should just run another VM on the Host, that should reduce the CPU usage magically,- cannot really say that worked for me. (tested on gentoo and debian hosts with other windows and debian VMs running)

I really dont know what to do next. If anyone has an idea please let me know, otherwise i will have to switch to xen/kvm.

comment:11 in reply to: ↑ 10 Changed 3 years ago by Roomer

Replying to Roomer:

I am running into the same problem with VirtualBox 2.6.10 and CentOS 5.4.

please replace every 2.6.10 by 3.2.10

comment:12 Changed 4 months ago by frank

  • Status changed from new to closed
  • Resolution set to obsolete
  • Description modified (diff)
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use