VirtualBox

Ticket #7607 (closed defect: obsolete)

Opened 3 years ago

Last modified 4 months ago

Windows Terminal Server 2008 unusably slow after upgrade from 3.2.4 and databases getting corrupted

Reported by: ToddAndMargo Owned by:
Priority: critical Component: other
Version: VirtualBox 3.2.10 Keywords:
Cc: Guest type: Windows
Host type: other

Description (last modified by frank) (diff)

Hi All,

This bug is being reported as critical as it corrupted one of my customers databases.

Host: Motherboard: Supermicro X8SAX Processor: x5650 (6 hard cores costing $1,200.00) Memory: 12 GB OS: CentOS 5.5 x64

Guest: Windows Terminal Server 2008 x32, Service Pack 2

VM: VBox 3.2.10

Before I get started, please note that bug 6928 was a Nested Paging bug and does not apply to this bug. The bug I am now reporting was uncovered while working on 6928.

On 2010-09-15 under bug 6928, I reported that when I upgrade from 3.2.4 to 3.2.8, with one software processor, that my Windows Terminal Server 2008 slowed to an excruciating crawl. I then reverted to 3.1.8 and got back to normal, still on one software processor.

On 10-18-2010 on bug 6928, I upgraded from 3.1.8 to 3.2.10 and from one soft processor to four hardware cores. The good news in that bug 6928 is fixed. The CPU storm is gone. But the massive slow down when I tried upgrading from 3.2.4 to 3.2.8 is still there. And it does not matter if you are using a single soft processor or multiple hard processors.

Note that Windows Terminal Server 2003, x32 worked beautifully under bug 6928's 3.2.10 patch. So, this bug is confined to Windows Terminal Server 2008 x32, SP2.

Also, in my 10-18-2010 testing of 3.2.10 on my Windows Terminal Server 2008 x32, SP2, a customer's database got corrupted. The report from the customer was that his program slowed down so excruciatingly slow that the whole thing eventually seized up. (I restored his database to Saturday night's snapshot. Fortunately, he did not use the server on Sunday.)

Please correct this bug as soon as possible. My Windows Terminal Server 2008 x32, SP2 is highly impacted, being relegated to one soft processor, and my customers are being poorly served. It would also be nice to FINALLY start being able to use my $1,200.00 processor.

I have attached both the 3.1.8 and the 3.2.10 XML files.

Please let me know if I can be of assistance in resolving this bug.

Many thanks, -T

Attachments

WS08-1.xml_3.1.8_10-17-2010 Download (9.1 KB) - added by ToddAndMargo 3 years ago.
3.1.8, one soft core, works correctly
WS08-1.xml_3.2.10_10-18-2010 Download (8.4 KB) - added by ToddAndMargo 3 years ago.
3.2.10, 4 hard cores, very very slow
ws08.log.zip Download (45.1 KB) - added by ToddAndMargo 3 years ago.
log files. 3.2.10 is probably .2 and .3

Change History

Changed 3 years ago by ToddAndMargo

3.1.8, one soft core, works correctly

Changed 3 years ago by ToddAndMargo

3.2.10, 4 hard cores, very very slow

Changed 3 years ago by ToddAndMargo

log files. 3.2.10 is probably .2 and .3

comment:1 Changed 3 years ago by sandervl73

If you really want help, you'll have to do better than this. Just a single report about some problem, without any description on how to reproduce it or if it's reproducable at all, is not sufficient.

comment:2 Changed 3 years ago by ToddAndMargo

How to reproduce:

  1. install VirtualBox-3.2-3.2.10_66523_rhel5-1.x86_64.rpm on CentOS 5.5 x64 with 12GB of RAM
  2. create a Windows Terminal Server 2008 x32, Service Pack 2 guest. Use my WS08-1.xml_3.2.10_10-18-2010 attachment. You may not be able to complete this step due to performance issues.
  3. run the guest. Note how excruciating slow it is. All functions are very, very slow. Watch how long it takes to paint screens: you can watch the strips appear one at a time. The slow down is universal.

As a baseline, try downgrading to 3.2.4 or 3.1.8 to see the actual speed the guest should run at. Please let me know it you need any further information or I can assist in any other manner.

Many thanks, -T

comment:3 Changed 3 years ago by ToddAndMargo

An update. My customer just lost a major customer of his over the poor performance of this virtual machine. (We are stuck with one soft processor due to this bug.) The complaint was the letters appeared several seconds after they were typed on the their remote RDP connection. If this bug does not get fixed soon, there will be no reason to apply the patch as this enterprise will be out of business. This is very, very serious. Please excuse the melodrama.

Also, I am still trying to get Oracle to sell my customer a support contract. I "finally" managed to speak to a sales representative yesterday. He said some from the support group would call me back yesterday or this morning. No joy. I will start calling all over Oracle *again*. Very frustrating.

Does anyone know how to get a support contract?

Many thanks, -T

comment:4 Changed 4 months ago by frank

  • Status changed from new to closed
  • Resolution set to obsolete
  • Description modified (diff)
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use