VirtualBox

Ticket #7569 (new defect)

Opened 4 years ago

Last modified 11 months ago

Virtualbox crash when user open page which use WebGL in Chrome 7 or Firefox 4

Reported by: czarek1986 Owned by:
Priority: critical Component: 3D support
Version: VirtualBox 3.2.8 Keywords: webgl, crash, firefox 4, chrome
Cc: Guest type: Windows
Host type: Windows

Description

When user try open page which use WebGL in Chrome 7 the browser window is frozen. If we try open the same page in Firefox 4 with WebGL turn on, VirtualBox wll crush and closed. Testing page is for example  http://html5test.com/

Attachments

Windows 7 64-bit-2012-02-10-12-25-39.log Download (107.3 KB) - added by Technologov 2 years ago.
VBox Log

Change History

comment:1 Changed 4 years ago by czarek1986

Problem in Windows XP 32b(host) -> Windows XP 32b (guest) and Windows 7 64b -> Windows XP 32b

comment:2 Changed 4 years ago by Technologov

+1

-Technologov

comment:3 Changed 3 years ago by stepheneb

I have a similar problem in a Windows 7 64-bit guest running in VBox v3.2.10 r66523.

When I try an open this very simple WebGL test page:

 http://learningwebgl.com/lessons/lesson01/index.html

in the the latest Chromium Canary release: "9.0.593.0 canary build" which is available for Windows here:

 http://tools.google.com/dlpage/chromesxs

The initial html content is displayed but the browser reports that the page has become: "unresponsive" while trying to initialize the WebGL canvas and offers to let me "Kill" the page.

I have 128 MB of video memory assigned to this Win7 instance and I have turned on both 2D and 3D acceleration in the Video Settings.

Minefield 4.0b8pre reports that is also: "Could not initialize WebGL".

comment:4 Changed 2 years ago by Technologov

Status update:

Host: Windows 7 x64 + NVIDIA GeForce GTX 560 + NV 285.62 + Chrome 17 + VBox 4.1.8 = WebGL works (also tried FFox 10, same result)

Guest: Windows 7 x64 (3D enabled) + Chrome 17 = WebGL FAILs. (also tried FFox 10, same result)

WebGL Test:  https://cvs.khronos.org/svn/repos/registry/trunk/public/webgl/sdk/demos/webkit/SpinningBox.html

More tests:  http://www.khronos.org/webgl/wiki/Demo_Repository

Supporting WebGL is important for web developers.

-Technologov

Changed 2 years ago by Technologov

VBox Log

comment:5 Changed 2 years ago by Technologov

UPDATE2: There is *no* crash, but just doesn't work.

comment:6 Changed 2 years ago by Technologov

comment:7 Changed 11 months ago by yuhong

It is disabled by default in current versions of Firefox because of the problem. You will have to force-enable it. It would be nice if someone did and fixed this bug.

Last edited 11 months ago by yuhong (previous) (diff)
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use