VirtualBox

Ticket #7553 (closed defect: fixed)

Opened 4 years ago

Last modified 3 years ago

Abnormal Memory Usage

Reported by: jabir_obaid@… Owned by:
Priority: major Component: other
Version: VirtualBox 3.2.8 Keywords: Memory leaks
Cc: Guest type: other
Host type: other

Description

When running WinXP 32 bit SP3 guest in Win7 64 bit, with folder sharing enabled and a heavy usage for network and sharing folder (I have a torrent app that stores the file in the shared folder) ,an abnormal memory usage for vbox process and keeps growing until either restart the process or the Win7 crashes.

Attachments

vbox_1.jpg Download (102.5 KB) - added by jabir_obaid@… 4 years ago.
vbox_2.jpg Download (9.7 KB) - added by jabir_obaid@… 4 years ago.
memory usage in Task manager
vbox_2.2.jpg Download (9.7 KB) - added by jabir_obaid@… 4 years ago.
memory eceeding 4 gb

Change History

Changed 4 years ago by jabir_obaid@…

Changed 4 years ago by jabir_obaid@…

memory usage in Task manager

Changed 4 years ago by jabir_obaid@…

memory eceeding 4 gb

comment:1 Changed 4 years ago by koma77

I'm experiencing this as well.

I have a linux host and a linux guest.

By simply using the network a lot by running Freenet the memory usage of virtualbox increases until there is no more memory left on the host.

The memory used by the guest, as perceived by the guest is still OK.

This makes virtualbox unusable for certain usage.

comment:2 Changed 4 years ago by frank

Duplicate of #6918? NAT networking involved?

comment:3 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Please reopen if still relevant with VBox 3.2.12 (there are leak fixes).

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use