VirtualBox

Ticket #754 (closed defect: fixed)

Opened 7 years ago

Last modified 4 years ago

PXE:Tftp Empty File Request

Reported by: bombela Owned by: michaln
Priority: major Component: other
Version: VirtualBox 1.5.0 Keywords:
Cc: Guest type: other
Host type: other

Description

When VirtualBox (1.5.0) send request to tftp serveur, the first request send the filename. If the first request abort, the second request will not send the filename ! The tftp server respond : error.

I have compared with Toshiba Laptop (Satellite pro 4600). The laprop send correctly the name at the second (or more) request.

I send a network snif in a file.

VirtualBox Network sniff :

  • VirtualBox : 192.168.0.67
  • TftpServer : 192.168.0.12

Tothiba Networdk sniff :

  • Toshiba : 192.168.0.57
  • TftpServer : 192.168.0.12

Compare each packet N°6 of Toshiba VirtalBox, in Toshiba sniff, you can see the filename but for the VirtualBox snif the filename is empty.

(And sorry for my bad english)

Attachments

toshiba_and_virtualbox.txt Download (7.7 KB) - added by bombela 7 years ago.

Change History

Changed 7 years ago by bombela

comment:1 Changed 7 years ago by michaln

  • Owner set to michaln
  • Status changed from new to assigned

Could you please tell me what exactly your PXE server software is? I already know about this problem but unfortunately the packet trace isn't sufficient to fix it. I'm sure I could fix this if I could reproduce the problem, but it appears to be specific only to some PXE server setups.

comment:2 Changed 7 years ago by klaus

Could you please provide a full-frame packet trace in pcap format? Many tools can create that format (wireshark, ethereal, tcpdump - but with tcpdump make sure you specify -s 1500 to capture all data). Please include the DHCP part, as that may be the cause of all the trouble.

comment:3 Changed 7 years ago by bombela

In less than 24h, i will make more packet trac.

I make juste the software i have tested :

I have tested with tftp serveur :

With this list you can see : tftp-hpa with SystemRescueCD is ok, but with my own config : no.

I will make many other test for check the configration diff. Not only in tftp serveur, but also in dhcp configuration. I suppose it's also very important.

Best regards,

comment:4 Changed 7 years ago by michaln

Yes, please make sure to include a complete DHCP packet trace. I have a strong suspicion that the DHCP packets are causing the problem (and it's not really caused by anything in TFTP). Is it possible that when PXE boot failed, there were multiple DHCP servers on your network? Perhaps your regular DHCP server plus a DHCP server built into the PXE server product?

comment:5 Changed 7 years ago by michaln

  • Status changed from assigned to closed
  • Resolution set to fixed

Actually, it looks like we won't need the packet trace. We got a trace from another customer, which allowed me to find and fix the problem. FYI, it would happen when a DHCP server sent option 67 (bootfile name) but not option 60 (PXEClient). That's why it showed up with some servers but not others. The fix will be in the next VBox release.

Should you still have trouble, please reopen this bug (with additional details).

comment:6 Changed 7 years ago by bombela

Great job. i wait the next release. Thanks.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use