VirtualBox

Ticket #7485 (closed defect: obsolete)

Opened 5 years ago

Last modified 4 weeks ago

"VBoxManage internalcommands createrawvmdk" Fatal error code 3479

Reported by: vladoos Owned by:
Priority: major Component: VM control
Version: VirtualBox 3.2.8 Keywords: VBoxManage
Cc: Guest type: other
Host type: Windows

Description (last modified by aeichner) (diff)

Microsoft Windows XP [Версия 5.1.2600] (С) Корпорация Майкрософт, 1985-2001.

C:\Program Files\Oracle\VirtualBox>VBoxManage -filename "%USERPROFILE%\.VirtualBox\HardDisks\localhost.vmdk" -rawdisk \.\PhysicalDrive0 Oracle VM VirtualBox Command Line Management Interface Version 3.2.8 (C) 2005-2010 Oracle Corporation All rights reserved.

ERROR: VMDK: could not create new file 'C:\Documents and Settings\user\.VirtualBo x\HardDisks\localhost.vmdk' Error code VERR_PATH_NOT_FOUND at D:\tinderbox\win-3.2\src\VBox\Devices\Storage\ VmdkHDDCore.cpp(3479) in function vmdkCreateRawImage Error while creating the raw disk VMDK: VERR_PATH_NOT_FOUND The raw disk vmdk file was not created

Change History

comment:1 Changed 5 years ago by pygo

I can confirm this problem with version 3.2.8. All current windows updates. Other VMs are otherwise working normally. Using windows 7 64bit.

Here is what I have:

c:\Program Files\Oracle\VirtualBox>VBoxManage.exe internalcommands createrawvmdk -filename c:\Users\pygo\.VirtualBox\VDI\disk2.vmdk -rawdisk \.\PhysicalDrive2
Oracle VM VirtualBox Command Line Management Interface Version 3.2.8 (C) 2005-2010 Oracle Corporation All rights reserved.

ERROR: VMDK: could not create new file 'c:\Users\pygo\.VirtualBox\VDI\disk2.vmdk'

Error code VERR_PATH_NOT_FOUND at D:\tinderbox\win-3.2\src\VBox\Devices\Storage\VmdkHDDCore.cpp(3479) in function vmdkCreateRawImage
Error while creating the raw disk VMDK: VERR_PATH_NOT_FOUND
The raw disk vmdk file was not created

c:\Program Files\Oracle\VirtualBox>

comment:2 Changed 5 years ago by pygo

I also believe the host type should be changed to windows.

comment:3 Changed 5 years ago by frank

  • Host type changed from other to Windows

comment:4 Changed 4 weeks ago by aeichner

  • Status changed from new to closed
  • Resolution set to obsolete
  • Description modified (diff)

Looks like the original issue could be a missing \ for the path to the physical drive, it should be \\.\PhysicalDrive2, closing as obsolete.

Last edited 4 weeks ago by aeichner (previous) (diff)
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use