VirtualBox

Ticket #7458 (closed defect: duplicate)

Opened 4 years ago

Last modified 3 years ago

Certain calls of VBoxManage clonehd produce a strange error

Reported by: pwabrahams Owned by:
Priority: major Component: other
Version: VirtualBox 3.2.8 Keywords: clonehd vboxmanage
Cc: Guest type: other
Host type: Linux

Description

With certain arguments, VBoxManage clonehd produces this strange error:

pwa@Asus-laptop:/aux/Virtual Drives$ VBoxManage clonehd "Windows XP Ultimate.vdi" WXPU2.vdi
Oracle VM VirtualBox Command Line Management Interface Version 3.2.8
(C) 2005-2010 Oracle Corporation
All rights reserved.

ERROR: Cannot register the hard disk '/aux/Virtual Drives/Windows XP Ultimate.vdi' with UUID {f7d38364-8b13-4b33-a804-214066c6b9b7} because a hard disk '/aux/Virtual Drives/Windows XP Ultimate.vdi' with UUID {f7d38364-8b13-4b33-a804-214066c6b9b7} already exists in the media registry ('/home/pwa/.VirtualBox/VirtualBox.xml')
Details: code NS_ERROR_INVALID_ARG (0x80070057), component VirtualBox, interface IVirtualBox, callee nsISupports
Context: "OpenHardDisk(Bstr(szFilenameAbs), AccessMode_ReadWrite, false, Bstr(""), false, Bstr(""), srcDisk.asOutParam())" at line 633 of file VBoxManageDisk.cpp

Note that the first argument has apparently been duplicated to create the second argument, which is why the target VDI appears to already exist. The error seems to be related to the use of relative rather than absolute paths, though some relative paths do work.

Change History

comment:1 Changed 4 years ago by bulletxt

I can confirm this bug. This bug does not happen with 3.2.6 .... Please fix it :°

comment:2 Changed 4 years ago by klaus

This is a long-standing bug, and it certainly is not regression since 3.2.6.

At the moment the workaround is to use absolute paths.

comment:3 Changed 4 years ago by klaus

  • Status changed from new to closed
  • Resolution set to duplicate

duplicate of #3552

comment:4 Changed 3 years ago by klaus

It is a duplicate of #3888. Sorry.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use