VirtualBox

Ticket #7448 (closed defect: fixed)

Opened 10 years ago

Last modified 9 years ago

VBoxNetFlt.sys XP BSOD twice in last week, ref #2929

Reported by: cgrandgent Owned by:
Component: network/hostif Version: VirtualBox 3.2.8
Keywords: Cc:
Guest type: other Host type: Windows

Description

twice in the last week. Minidump at  http://www.chuckg.com/Mini090810-01.dmp Heavy network activity on my system at both times. Reference "Ticket #2929 (closed defect: fixed)"

Attachments

Mini090810-01.dmp Download (88.0 KB) - added by cgrandgent 10 years ago.
Logs.zip Download (30.3 KB) - added by cgrandgent 10 years ago.
Mini091010-01.dmp Download (88.0 KB) - added by cgrandgent 10 years ago.
Mini091010-01.2.dmp Download (88.0 KB) - added by cgrandgent 10 years ago.
Logs2.zip Download (43.4 KB) - added by cgrandgent 10 years ago.
Logs.2.zip Download (44.7 KB) - added by inegodov 10 years ago.
Dumps.zip Download (51.3 KB) - added by inegodov 10 years ago.

Change History

Changed 10 years ago by cgrandgent

comment:1 follow-up: ↓ 3 Changed 10 years ago by misha

Just do double-check: do you have any VMs using running when the bsod occurs? If yes, please attach session log files for those VMs.

comment:2 Changed 10 years ago by misha

We've made a fix that should prevent the crash you observed. Please drop me a mail at mikhail dot sennikovsky at sun dot com I'll then send you a link to a test build containing the fix.

Changed 10 years ago by cgrandgent

comment:3 in reply to: ↑ 1 Changed 10 years ago by cgrandgent

Replying to misha:

Just do double-check: do you have any VMs using running when the bsod occurs? If yes, please attach session log files for those VMs.

I've attached the logfiles.

Chuck

comment:4 Changed 10 years ago by cgrandgent

just happened again, minidump and logfiles attached......

Changed 10 years ago by cgrandgent

Changed 10 years ago by cgrandgent

Changed 10 years ago by cgrandgent

comment:5 Changed 10 years ago by frank

  • Component changed from other to network/hostif

comment:6 Changed 10 years ago by frank

  • Host type changed from other to Windows

comment:7 Changed 10 years ago by misha

  • Status changed from new to closed
  • Resolution set to fixed

Since there is no feedback since the test build I provided, the bug is considered fixed. Please re-open if needed.

comment:8 Changed 10 years ago by cgrandgent

Yes, I have had no crashes since the test build, thanx !

Chuck

Changed 10 years ago by inegodov

Changed 10 years ago by inegodov

comment:9 Changed 10 years ago by inegodov

  • Status changed from closed to reopened
  • Resolution fixed deleted

Since I have installed the test build (22.09.2010) my system was working without an issue until yesterday (11.10.2010). Then I have got absolutely the same BSOD. I am attaching logs and dumps from my computer.

comment:10 follow-up: ↓ 11 Changed 10 years ago by frank

So I assume the same happens with VBox 3.2.10? Any idea how to reproduce this BSOD?

comment:11 in reply to: ↑ 10 ; follow-up: ↓ 12 Changed 10 years ago by cgrandgent

I have not seen it since I got the test build, nor since 3.2.10 which also has the fix. However, I believe it is related to heavy non-VBox network activity. I never saw the BSOD until I started streaming media on a different network interface on this box, then I saw the BSOD 3 times in approximately one week.

Replying to frank:

So I assume the same happens with VBox 3.2.10? Any idea how to reproduce this BSOD?

comment:12 in reply to: ↑ 11 Changed 10 years ago by inegodov

Yes, it happens also on 3.2.10 Just survived another BSOD. I was copying about 4GB of middle-size files to the server when it crashed. I tend to beleive that BSODs are the result of the race conditions (exactly as cgrandgent wrote). I have configured network adapter in VBox to NAT (instead of Bridged). Will see if helps.

comment:13 Changed 10 years ago by inegodov

UPDATE: Had to switch back to Bridged - one of the applications I am using VBox for, is not working via NAT.

comment:14 Changed 10 years ago by frank

Please have a look at ticket #7601 and try the test build posted there.

comment:15 Changed 9 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

No response, closing.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use