VirtualBox

Ticket #7427 (reopened defect)

Opened 4 years ago

Last modified 7 months ago

Kernel panic when starting F5 Big-IP (not syncing: Fatal exception)

Reported by: tbehrens Owned by:
Priority: major Component: virtual disk
Version: VirtualBox 3.2.8 Keywords:
Cc: Guest type: Linux
Host type: Windows

Description (last modified by frank) (diff)

I spun up an F5 Big-IP trial VM on VirtualBox. It can be found here:  https://www.f5.com/trial/. It's designed to run on VMWare.

The disk I use is the original VMDK that comes from F5. I've set up a virtual machine with PIIX4, I/O APIC. Base memory is 1GB, network interfaces are PCNet-II. This all matches the VMWare setup.

Upon boot, after Loading udev, I get "Kernel panic - not syncing: Fatal exception"

The interesting part is that this does not happen always. If you allow the VM to auto-reboot, eventually it will load successfully. This makes me think that we may have some sort of race condition here. I am assuming at this point that it has something to do with attaching the storage devices from /etc/fstab, though I do not know this for certain.

The one thing I can see that is slightly unusual is that /etc/fstab uses UUIDs, not /dev/hda references.

This should be easy to reproduce by downloading the F5 trial and using the attached machine XML.

Attachments

BIGIP-10.1.0.3341.1084.xml Download (6.4 KB) - added by tbehrens 4 years ago.
F5 BigIP LTM Virtual Machine XML

Change History

Changed 4 years ago by tbehrens

F5 BigIP LTM Virtual Machine XML

comment:1 Changed 3 years ago by tbehrens

Resolved in VirtualBox 3.2.12.

comment:2 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Thanks for the feedback!

comment:3 Changed 2 years ago by kampa

  • Status changed from closed to reopened
  • Resolution fixed deleted

I have the same problem ("Kernel panic - not syncing: Fatal exception") with the VirtualBox v4.1.8 on the Windows Host. I have tried with the flag for the ciphset PIIX3 and ICH9 with IO APIC.

Any ideas?

Thanks

comment:4 Changed 19 months ago by frank

  • Description modified (diff)

kampa, still relevant with VBox 4.1.22? If so, please attach a VBox.log file of such a VM session.

comment:5 Changed 19 months ago by tbehrens

I tested my old LTM 10.1.0 image with 4.1.6 and 4.1.22. No issues.

Currently importing the LTM 11.2.1 image (VMWare ESXi version) into VBox to test that image, as well. It uses PC-Net FAST III and LsiLogic SCSI, so quite a different underlying OS configuration.

comment:6 Changed 11 months ago by aeichner

  • Status changed from reopened to closed
  • Resolution set to fixed

Tried it myself now with the appliance from F5. Works without issues here, closing this defect. Please reopen if necessary.

comment:7 Changed 10 months ago by Masterbaker

  • Status changed from closed to reopened
  • Resolution fixed deleted

Should be reopened - I just imported the BigIP Virtual Edition (OVA) file fresh from F5 and i'm also getting multiple kernel panics. The VM eventually manages to boot up and work...

BigIP Virtual Edition Version : BIGIP-10.1.0.3341.1084.OVA

VirtualBox Version : 4.2.14 r86644

comment:8 Changed 10 months ago by tbehrens

"Works for me" - with BigIP-10.1.0 and VB 4.2.14, on Win7 x64. Settings for the F5 VM:

1 CPU, 1GB RAM
Chipset PIIX3
Enable IO APIC
Hardware clock in UTC

IDE Controller PIIX3
Use host I/O cache

First Ethernet adapter (the only one I use) is PCnet-FAST III

comment:9 Changed 7 months ago by frank

Masterbaker, did you try the settings provided by tbehrens?

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use