VirtualBox

Ticket #7422 (new defect)

Opened 4 years ago

Last modified 7 months ago

Seamless Mode Breaks Gnome Panel

Reported by: GeorgeSalt Owned by:
Priority: major Component: GUI/seamless
Version: VirtualBox 3.2.8 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

Host: Ubuntu Linux 10.04 with kernel 2.6.32-24-generic on x86_64 and Gnome 2.30.2.

VirtualBox: 3.2.8 r64453

VM: Windows XP Professional (32 bit)

Problem: When I switch the VM to Seamless Mode, the panels on my Gnome desktop become unresponsive; for example, the "Applications" pulldown menu will not expand when clicked. This problem goes away when I switch back to windowed mode.

This problem started recently, after an Ubuntu package upgrade which included a new linux kernel.

Attachments

Visual-Studio-XP-32-2010-09-29-14-58-20.log Download (68.5 KB) - added by Perryg 4 years ago.
This one from svn build
Windows XPpro 32-2010-09-29-14-52-16.log Download (81.8 KB) - added by Perryg 4 years ago.
This one from 3.2.8

Change History

comment:1 Changed 4 years ago by Perryg

I think the better way to explain this is with Ubuntu as host and xp as guest in seamless, if the host does not have direct focus the drop downs are covered with the overlay. I have confirmed this as well.

Also tested with svn at 32802 and still present. Others affected are here  http://forums.virtualbox.org/viewtopic.php?f=7&t=34613&start=0

Log files to follow.

Changed 4 years ago by Perryg

This one from svn build

Changed 4 years ago by Perryg

This one from 3.2.8

comment:2 Changed 4 years ago by hobbyhack

Here are my notes on the issue that might help.

Symptoms:

  • After I click focus in a full screen virtual box I can no longer use my top gnome panel (start bar) on the host. If I click on Applications for example I can see that it has put a frame around the button, showing it was clicked, but the drop down menu never shows up.
  • I can click on anything else on the host without issues.
  • If I click on a window in the host I can then use the host gnome panel normally again.
  • Gnome panel still autohides and unhides
  • Lower Gnome panel "task bar" is unaffected
  • Window mode works fine. This only happens in full screen mode and seamless.

My setup:

  • Host: Pretty standard Ubuntu 10.04 install. Virtualbox 3.2.8 and 3.2.10- installed from package provided by downlaod.virtualbox.org repositories.
  • Hardware: whitebox, 8gb of RAM, Nvidia graphics (compiz is working), Intel Core2Duo Quad, dedicated system and dedicated virtualbox hard drives using ext4 file systems (this is why I waited to install 3.2.x), logitech mx revolution mouse (btnx is installed), logitech g15 keyboard (with g15daemon and g15macro installed), 2 monitors (host on one, guest on the other in full screen)
  • Guest OSes: Mostly debian squeeze servers but I also have a Ubuntu 10.04 guest for home stuff and a Windows XP guest for work
  • Guest settings: New setting "Enable absolute pointing device" = disabled, USB is enabled but not in use

Testing/Results:

  • Upgraded guest additions to 3.2.8 - no change
  • Uninstalled and resinstalled guest additions - no change
  • Ubuntu and Windows guests have the same effect
  • Tried with guest 3d and 2d disabled and enabled - no change
  • Problem was found in virtual 3.2.8 and 3.2.10. Problem goes away when downgrading to 3.1.8. I did not test any other versions.

comment:3 Changed 3 years ago by GeorgeSalt

Upgrading to 3.2.10 does not fix the problem.

comment:4 Changed 3 years ago by GeorgeSalt

Upgrading to 3.2.12 does not fix the problem.

comment:5 Changed 3 years ago by bbbco

I experience this as well using Fedora 13 host and Windows 7 guest in VB 4.0

comment:6 Changed 3 years ago by jasondbrewer

I've encountered what seems to be this same issue as well.. If I've put focus on my VirtualBox seamless mode window (left monitor), I have to click on another application window in my Fedora/Gnome environment (right monitor) before I can use the Gnome Panel. Similar to the descriptoin by @hobbyhack, the Gnome Panel doesn't lock up for me exactly, but the menus aren't able to display (if I click on Applications, Places, or System). I have to click on another application window to return the Gnome Panel to normal operation.

I have what seems to be a related issue with SynergyPlus (aka Synergy+ and synergy-plus). I was hoping it could shed light on this existing "Gnome Panel" issue, possibly helping to highlight the right area of the Gnome system with which VirtualBox has a compatibility issue.

Host: Fedora 13, 64-bit
VirtualBox: 4.0-4.0.0_69151_fedora13-1.x86_64 Guest: Windows 7 Pro, 64-bit
SynergyPlus server (has keyboard/mouse plugged in): 1.3.4-5.fc13.x86_64
SynergyPlus client: 1.3.4 (Windows XP Pro SP3, 32-bit)
Left monitor: VirtualBox session in seamless mode
Right monitor: Gnome desktop
Far-right monitor (virtual via SynergyPlus): XP machine

If I've put focus on my VirtualBox seamless session (left monitor), I have to click on another application window in my Fedora environment (right monitor) before I can use the my Windows XP machine via SynergyPlus (far right). While the resulting anomaly on Gnome Panel is that the menus never pop up, the symptom with SynergyPlus is that the mouse pointer disappears.

After moving my mouse from the VirtualBox seamless session across the right monitor and then out of frame to the far right monitor (without clicking any other application windows in Linux), my mouse pointer disappears and shows no signs of clicking anything on any of the three monitors. The way to bring my mouse pointer back from this stranded VirtualBox/SynergyPlus scenario is by pressing the VirtualBox "host key" (F7 in my case).

comment:7 Changed 3 years ago by michael

My guess at why this is happening is as follows. When we have the focus we normally grab the keyboard which lets us handle more keys and key combinations than we could otherwise. However, when we are not in seamless mode we use a weaker form of grab which for technical reasons related to X11 we can't do while in seamless or fullscreen mode. The strong grab that we do in seamless mode will prevent any other application from grabbing the keyboard, and I strongly suspect that the GNOME panel applications are simply refusing to work if they can't grab the keyboard rather than gracefully reducing their functionality slightly (which we do if we can't grab it). Certainly the following snippet from the gtk+ menu code (gtk/gtkmenu.c:1517 from gtk+2.0-2.22.0 as it comes with Ubuntu 10.10) suggests this (I don't actually know whether or not this is the same code that is used for the panel).

  if (!GTK_MENU_SHELL (xgrab_shell)->have_xgrab)
    {
      /* We failed to make our pointer/keyboard grab. Rather than leaving the us
er
       * with a stuck up window, we just abort here. Presumably the user will
       * try again.
       */

You might want to ask the GNOME/gtk+ people about this. GNOME panel refusing to work if an application has a grab on the keyboard - if that is really what is happening - seems a bit radical to me.

comment:8 Changed 3 years ago by stfloris

I don't know if it's useful, but I have solved the problem disabling the "Auto Capture Keyboard" in Virtualbox <File-Preferences-Input>.

comment:9 Changed 3 years ago by justin.zy.wang@…

Upgrading to 4.0.4 does not fix the problem.

comment:10 Changed 3 years ago by jasondbrewer

Version 4.0.6 didn't fix this either.

comment:11 Changed 3 years ago by jasondbrewer

Version 4.0.8 didn't fix this either.

Neither Seamless nor Fullscreen modes are able to switch focus to Gnome Panel/menu or to offscreen monitor (Synergy) when VirtualBox's "Auto Capture Keyboard" option is turned on.

comment:12 in reply to: ↑ description Changed 3 years ago by berns

Version 4.0.8 and Ubuntu 11.04 does not behave different than 10.04.

Disabling the keyboard capture with the host key before clicking the gnome menu also lets the menu appear :) - that's at least a "workaround".

comment:13 Changed 3 years ago by jasondbrewer

Version 4.1.0 still has problems in Gnome with the "Auto Capture Keyboard" feature. The same symptoms persist when it's turned on.

comment:14 Changed 3 years ago by jasondbrewer

This same issue persists with VirtualBox version 4.1.2.

comment:15 Changed 7 months ago by rugubara

I experience this behavior on Gentoo Linux host VB 4.2.8 and Gnome 3. Workarounds: hitting the host key activates the Gnome Shell panel, disabling auto keyboard capture also gives to Gnome panel. However, sometimes the panel works w/o using the host key/disabling keyb capture. I couldn't figure out when it happens.

Last edited 7 months ago by rugubara (previous) (diff)
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use