VirtualBox

Ticket #7406 (closed defect: wontfix)

Opened 4 years ago

Last modified 4 years ago

Guest - OSX Server 10.6 will not boot/install on MacBookPro6,2 but does work on MacPro4,1

Reported by: feral.and.abberrant Owned by:
Priority: major Component: installer
Version: VirtualBox 3.2.8 Keywords:
Cc: Guest type: OSX Server
Host type: Mac OS X

Description

OSX Server 10.6 does not boot on MacBookPro6,2 ( black screen or complaints about not being able to read mach_kernel.mkext ) but work perfectly on MacPro4,1.

Trying to boot with the guest in 32bit mode - I see a black window ( that never progresses to the VirtualBox bios/efi boot screen ) - When I reboot the guest into x64 bit mode, I can then boot the guest slightly farther ( the window resizes, the efi/bios boot screen is displayed it appears that OSX tries to load), but it reports that it cannot find the 'mach_kernel.mkext' and then kernel panics. ( Having the host in 32 or 64 bit mode, does not appear to matter. )

I'm booting the guest from an OSX Server 10.6 iso.

My host system is a Core i7 MacBookPro6,2, running VirtualBox Version 3.2.8 r64453

My other host system is a MacPro4,1 running VirtualBox Version 3.2.0 r61806 - and this system has no problem installing OSX Server Snow Leopard, from this ISO.

I've already tried uninstalling VBox 3.2.8 and installing 3.2.0 from the same .dmg file that was used to install VBox on the MacPro, and it didn't resolve the problem - so I'm assuming that the issue is related to my MacBookPro's ACPI or EFI....

I've included my VBox.log and some screen shots...

Attachments

Screen shot 2010-08-31 at 11.05.35 AM.png Download (17.4 KB) - added by feral.and.abberrant 4 years ago.
inital osx boot screen
Screen shot 2010-08-31 at 11.09.18 AM.png Download (73.1 KB) - added by feral.and.abberrant 4 years ago.
and kernel panic screen

Change History

Changed 4 years ago by feral.and.abberrant

inital osx boot screen

Changed 4 years ago by feral.and.abberrant

and kernel panic screen

comment:1 in reply to: ↑ description Changed 4 years ago by feral.and.abberrant

Replying to feral.and.abberrant:

OSX Server 10.6 does not boot on MacBookPro6,2 ( black screen or complaints about not being able to read mach_kernel.mkext ) but work perfectly on MacPro4,1.

Trying to boot with the guest in 32bit mode - I see a black window ( that never progresses to the VirtualBox bios/efi boot screen ) - When I reboot the guest into x64 bit mode, I can then boot the guest slightly farther ( the window resizes, the efi/bios boot screen is displayed it appears that OSX tries to load), but it reports that it cannot find the 'mach_kernel.mkext' and then kernel panics. ( Having the host in 32 or 64 bit mode, does not appear to matter. )

I'm booting the guest from an OSX Server 10.6 iso.

My host system is a Core i7 MacBookPro6,2, running VirtualBox Version 3.2.8 r64453

My other host system is a MacPro4,1 running VirtualBox Version 3.2.0 r61806 - and this system has no problem installing OSX Server Snow Leopard, from this ISO.

I've already tried uninstalling VBox 3.2.8 and installing 3.2.0 from the same .dmg file that was used to install VBox on the MacPro, and it didn't resolve the problem - so I'm assuming that the issue is related to my MacBookPro's ACPI or EFI....

I've included my VBox.log and some screen shots...

'Apologies for polluting the BugTracker - It appears that the MacBookPro simply isn't supported by that version of OSX Server... This issue can be considered resolved.

comment:2 Changed 4 years ago by ni81036

  • Status changed from new to closed
  • Resolution set to wontfix
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use