VirtualBox

Ticket #7388 (closed defect: fixed)

Opened 4 years ago

Last modified 4 years ago

Segfault when passing UTF8 character on VBoxManage controlvm option => Fixed in SVN

Reported by: sergiomacedo Owned by:
Priority: trivial Component: VM control
Version: VirtualBox 3.2.8 Keywords: UTF8 VBoxManage segfault
Cc: Guest type: Linux
Host type: Linux

Description

Minor argument parsing issue.

While executing some operations on a stopped VM with my keyboard set to PT-BR on an Ubuntu host (generating dual-byte special characters), VBoxManage returned a segfault when receiving an option which was wrongly written with such character.

Attached are:

  • The VBoxManage core file
  • A text/shell file with the garbled option.

I did not try to reproduce the event with other options than the used on the sample provided.

It's not a show stopper but I hope this information can help VB team to improve the argument parsing to avoid something worst on another place.

Attachments

crashing-call.sh Download (96 bytes) - added by sergiomacedo 4 years ago.
Text file with command able to cause the error.

Change History

Changed 4 years ago by sergiomacedo

Text file with command able to cause the error.

comment:1 Changed 4 years ago by sergiomacedo

I couldn't upload the 2.8MB core file to the bugtrack.

If considered really necessary (shouldn't be, because the error is reproductible easily enough), I can add it splitted on smaller parts.

Please let me know.

comment:2 Changed 4 years ago by frank

Thanks, I think an upload of the core dump shouldn't be necessary, I hope we can reproduce the crash.

comment:3 Changed 4 years ago by frank

Actually I can NOT reproduce this problem. VBoxManage reports unknown option. Are you sure this was VBox 3.2.8?

comment:4 Changed 4 years ago by sergiomacedo

Yes, I'm sure.

Just to clarify the setup (what I wrote on the description doesn't match 100% the scenario and may be the reason you couldn't reproduce the problem):

  • Host where the VirtualBox was running: Centos with UTF8 disabled (LANG=C)
  • Management station: Ubuntu with LANG=en_US.UTF-8

I opened a gnome terminal on the ubuntu station, ssh'd to the VBox host and there typed the VBoxManage command that caused the error.

Anyway, here's a link to the VBoxManage core.

 http://hiangel.tmp.com.br/VBoxManage.core.bz2

Thanks for the attention.

comment:5 Changed 4 years ago by frank

Thanks, LC_ALL=C was the missing bit. I finally was able to reproduce this problem.

comment:6 Changed 4 years ago by frank

  • Summary changed from Segfault when passing UTF8 character on VBoxManage controlvm option to Segfault when passing UTF8 character on VBoxManage controlvm option => Fixed in SVN

Finally fixed in SVN. The fix will also be included in the next maintenance release.

comment:7 Changed 4 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use