VirtualBox

Ticket #7379 (closed defect: duplicate)

Opened 4 years ago

Last modified 4 years ago

Problem ptr.h in FreeBSD - Managed pointer must not be null

Reported by: Dorlas Owned by:
Priority: major Component: other
Version: VirtualBox 3.2.8 Keywords:
Cc: Guest type: other
Host type: other

Description

Using FreeBSD 8.1-RELEASE (as a host) (i386) and VirtualBox 3.2.8.

Crash (core dump) some commands and rips on ptr.h.

Example:

vboxwebsrv
Oracle VM VirtualBox web service version 3.2.8_OSE
(C) 2005-2010 Oracle Corporation
All rights reserved.
Type Manifest File: /root/.VirtualBox/xpti.dat
nsNativeComponentLoader: autoregistering begins.
nsNativeComponentLoader: autoregistering succeeded
nNCL: registering deferred (0)
2010-08-26 08:35:42 [ P ] Socket connection successful: host = default (localhost), port = 18083, master socket = 11
2010-08-26 08:35:58 [ P ] Request 1 on socket 12 queued for processing (1 items on Q)
2010-08-26 08:35:58 [ P ] Request 2 on socket 14 queued for processing (2 items on Q)
2010-08-26 08:35:58 [ P ] Request 3 on socket 15 queued for processing (3 items on Q)
2010-08-26 08:35:58 [ P ] Request 4 on socket 16 queued for processing (4 items on Q)
2010-08-26 08:35:58 [ 1] New SOAP thread started
2010-08-26 08:35:58 [ 1] Processing connection from IP=127.0.0.1 socket=12 (0 out of 1 threads idle)
2010-08-26 08:35:58 [ P ] Request 5 on socket 17 queued for processing (4 items on Q)
2010-08-26 08:35:58 [ 2] New SOAP thread started
2010-08-26 08:35:58 [ 2] Processing connection from IP=127.0.0.1 socket=14 (0 out of 2 threads idle)

!!Assertion Failed!!
Expression: p
Location : /backup/ports/emulators/virtualbox-ose/work/VirtualBox-3.2.8_OSE/include/VBox/com/ptr.h(236) ComPtrBase<C>::NoAddRefRelease<C>* ComPtrBase<C>::operator->() const [with C = ISystemProperties]
Managed pointer must not be null
Trace/BPT trap(core dumped)

Debug core:

gdb /usr/local/bin/vboxwebsrv -c vboxwebsrv.core
GNU gdb 6.1.1 [FreeBSD]
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB. Type "show warranty" for details.
This GDB was configured as "i386-marcel-freebsd"...
Core was generated by `vboxwebsrv'.
Program terminated with signal 5, Trace/breakpoint trap.
Reading symbols from /usr/local/lib/virtualbox/VBoxRT.so...done.
Loaded symbols for /usr/local/lib/virtualbox/VBoxRT.so
Reading symbols from /usr/local/lib/virtualbox/VBoxXPCOM.so...done.
Loaded symbols for /usr/local/lib/virtualbox/VBoxXPCOM.so
Reading symbols from /usr/lib/libstdc++.so.6...done.
Loaded symbols for /usr/lib/libstdc++.so.6
Reading symbols from /lib/libm.so.5...done.
Loaded symbols for /lib/libm.so.5
Reading symbols from /lib/libgcc_s.so.1...done.
Loaded symbols for /lib/libgcc_s.so.1
Reading symbols from /lib/libc.so.7...done.
Loaded symbols for /lib/libc.so.7
Reading symbols from /usr/local/lib/libiconv.so.3...done.
Loaded symbols for /usr/local/lib/libiconv.so.3
Reading symbols from /usr/lib/librt.so.1...done.
Loaded symbols for /usr/lib/librt.so.1
Reading symbols from /lib/libz.so.5...done.
Loaded symbols for /lib/libz.so.5
Reading symbols from /lib/libthr.so.3...done.
Loaded symbols for /lib/libthr.so.3
Reading symbols from /lib/libcrypto.so.6...done.
Loaded symbols for /lib/libcrypto.so.6
Reading symbols from /usr/lib/libssl.so.6...done.
Loaded symbols for /usr/lib/libssl.so.6
Reading symbols from /usr/local/lib/libxml2.so.5...done.
Loaded symbols for /usr/local/lib/libxml2.so.5
Reading symbols from /usr/local/lib/libcurl.so.6...done.
Loaded symbols for /usr/local/lib/libcurl.so.6
Reading symbols from /usr/local/lib/virtualbox/components/VBoxXPCOMIPCC.so...done.
Loaded symbols for /usr/local/lib/virtualbox/components/VBoxXPCOMIPCC.so
Reading symbols from /usr/local/lib/virtualbox/components/VBoxSVCM.so...done.
Loaded symbols for /usr/local/lib/virtualbox/components/VBoxSVCM.so
Reading symbols from /usr/local/lib/virtualbox/components/VBoxC.so...done.
Loaded symbols for /usr/local/lib/virtualbox/components/VBoxC.so
Reading symbols from /usr/local/lib/virtualbox/VBoxVMM.so...done.
Loaded symbols for /usr/local/lib/virtualbox/VBoxVMM.so
Reading symbols from /usr/local/lib/virtualbox/VBoxREM.so...done.
Loaded symbols for /usr/local/lib/virtualbox/VBoxREM.so
Reading symbols from /usr/local/lib/libpng.so.6...done.
Loaded symbols for /usr/local/lib/libpng.so.6
Reading symbols from /libexec/ld-elf.so.1...done.
Loaded symbols for /libexec/ld-elf.so.1
#0 0x0805697f in ComPtrBase<ISystemProperties>::operator-> (this=0xbf899d7c) at ptr.h:236
236 AssertMsg(p, ("Managed pointer must not be null\n"));
[New Thread 29d0ad80 (LWP 100261)]
[New Thread 29d0aec0 (LWP 100258)]
[New Thread 293ac9c0 (LWP 100260)]
[New Thread 293acb00 (LWP 100259)]
[New Thread 293acc40 (LWP 100257)]
[New Thread 293ad140 (LWP 100256)]
[New Thread 293ad280 (LWP 100250)]
[New Thread 29301140 (LWP 100137)]
(gdb) bt
#0 0x0805697f in ComPtrBase<ISystemProperties>::operator-> (this=0xbf899d7c) at ptr.h:236
#1 0x0804e5c5 in WebServiceSession::authenticate (this=0x296ffe80, pcszUsername=0x29dd67dc "ian", pcszPassword=0x296ffd0c "pass")
at /backup/ports/emulators/virtualbox-ose/work/VirtualBox-3.2.8_OSE/src/VBox/Main/webservice/vboxweb.cpp:1148
#2 0x0804ec78 in __vbox__IWebsessionManager_USCORElogon (req=0x29dd67f0, resp=0xbf899e34)
at /backup/ports/emulators/virtualbox-ose/work/VirtualBox-3.2.8_OSE/src/VBox/Main/webservice/vboxweb.cpp:1646
#3 0x080fc73f in soap_serve___vbox__IWebsessionManager_USCORElogon (soap=0x296a7000)
at /backup/ports/emulators/virtualbox-ose/work/VirtualBox-3.2.8_OSE/out/freebsd.x86/debug/obj/webservice/soapServer.cpp:26580
#4 0x0817d620 in soap_serve_request (soap=0x296a7000)
at /backup/ports/emulators/virtualbox-ose/work/VirtualBox-3.2.8_OSE/out/freebsd.x86/debug/obj/webservice/soapServer.cpp:1311
#5 0x0817e024 in soap_serve (soap=0x296a7000)
at /backup/ports/emulators/virtualbox-ose/work/VirtualBox-3.2.8_OSE/out/freebsd.x86/debug/obj/webservice/soapServer.cpp:54
#6 0x0804ff22 in SoapThread::process (this=0x2968dee0)
at /backup/ports/emulators/virtualbox-ose/work/VirtualBox-3.2.8_OSE/src/VBox/Main/webservice/vboxweb.cpp:455
#7 0x08058a47 in SoapThread::fntWrapper (pThread=0x296f3c00, pvThread=0x2968dee0)
at /backup/ports/emulators/virtualbox-ose/work/VirtualBox-3.2.8_OSE/src/VBox/Main/webservice/vboxweb.cpp:290
#8 0x28968b8c in rtThreadMain (pThread=0x296f3c00, NativeThread=701542080, pszThreadName=0x296f4188 "SoapQWrk01")
at /backup/ports/emulators/virtualbox-ose/work/VirtualBox-3.2.8_OSE/src/VBox/Runtime/common/misc/thread.cpp:679
#9 0x289d4175 in rtThreadNativeMain (pvArgs=0x296f3c00)
at /backup/ports/emulators/virtualbox-ose/work/VirtualBox-3.2.8_OSE/src/VBox/Runtime/r3/posix/thread-posix.cpp:227
#10 0x28f1875f in pthread_getprio () from /lib/libthr.so.3
#11 0x00000000 in ?? ()

Next, using command: VBoxManage setproperty websrvauthlibrary null

Crash:

VBoxManage setproperty websrvauthlibrary null
Oracle VM VirtualBox Command Line Management Interface Version 3.2.8_OSE
(C) 2005-2010 Oracle Corporation
All rights reserved.

Type Manifest File: /root/.VirtualBox/xpti.dat
nsNativeComponentLoader: autoregistering begins.
nsNativeComponentLoader: autoregistering succeeded
nNCL: registering deferred (0)

!!Assertion Failed!!
Expression: p
Location : /backup/ports/emulators/virtualbox-ose/work/VirtualBox-3.2.8_OSE/include/VBox/com/ptr.h(236) ComPtrBase<C>::NoAddRefRelease<C>* ComPtrBase<C>::operator->() const [with C = ISystemProperties]
Managed pointer must not be null
Trace/BPT trap(core dumped)

Debug:

gdb /usr/local/bin/VBoxManage -c VBoxManage.core
GNU gdb 6.1.1 [FreeBSD]
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB. Type "show warranty" for details.
This GDB was configured as "i386-marcel-freebsd"...
Core was generated by `VBoxManage'.
Program terminated with signal 5, Trace/breakpoint trap.
Reading symbols from /usr/local/lib/virtualbox/VBoxDDU.so...done.
Loaded symbols for /usr/local/lib/virtualbox/VBoxDDU.so
Reading symbols from /usr/local/lib/virtualbox/VBoxRT.so...done.
Loaded symbols for /usr/local/lib/virtualbox/VBoxRT.so
Reading symbols from /usr/local/lib/virtualbox/VBoxXPCOM.so...done.
Loaded symbols for /usr/local/lib/virtualbox/VBoxXPCOM.so
Reading symbols from /usr/lib/libstdc++.so.6...done.
Loaded symbols for /usr/lib/libstdc++.so.6
Reading symbols from /lib/libm.so.5...done.
Loaded symbols for /lib/libm.so.5
Reading symbols from /lib/libgcc_s.so.1...done.
Loaded symbols for /lib/libgcc_s.so.1
Reading symbols from /lib/libc.so.7...done.
Loaded symbols for /lib/libc.so.7
Reading symbols from /lib/libthr.so.3...done.
Loaded symbols for /lib/libthr.so.3
Reading symbols from /usr/local/lib/libiconv.so.3...done.
Loaded symbols for /usr/local/lib/libiconv.so.3
Reading symbols from /usr/lib/librt.so.1...done.
Loaded symbols for /usr/lib/librt.so.1
Reading symbols from /lib/libz.so.5...done.
Loaded symbols for /lib/libz.so.5
Reading symbols from /lib/libcrypto.so.6...done.
Loaded symbols for /lib/libcrypto.so.6
Reading symbols from /usr/lib/libssl.so.6...done.
Loaded symbols for /usr/lib/libssl.so.6
Reading symbols from /usr/local/lib/libxml2.so.5...done.
Loaded symbols for /usr/local/lib/libxml2.so.5
Reading symbols from /usr/local/lib/libcurl.so.6...done.
Loaded symbols for /usr/local/lib/libcurl.so.6
Reading symbols from /usr/local/lib/virtualbox/components/VBoxXPCOMIPCC.so...done.
Loaded symbols for /usr/local/lib/virtualbox/components/VBoxXPCOMIPCC.so
Reading symbols from /usr/local/lib/virtualbox/components/VBoxSVCM.so...done.
Loaded symbols for /usr/local/lib/virtualbox/components/VBoxSVCM.so
Reading symbols from /usr/local/lib/virtualbox/components/VBoxC.so...done.
Loaded symbols for /usr/local/lib/virtualbox/components/VBoxC.so
Reading symbols from /usr/local/lib/virtualbox/VBoxVMM.so...done.
Loaded symbols for /usr/local/lib/virtualbox/VBoxVMM.so
Reading symbols from /usr/local/lib/virtualbox/VBoxREM.so...done.
Loaded symbols for /usr/local/lib/virtualbox/VBoxREM.so
Reading symbols from /usr/local/lib/libpng.so.6...done.
Loaded symbols for /usr/local/lib/libpng.so.6
Reading symbols from /libexec/ld-elf.so.1...done.
Loaded symbols for /libexec/ld-elf.so.1
#0 0x0805c5df in ComPtrBase<ISystemProperties>::operator-> (this=0xbfbfe654) at ptr.h:236
236 AssertMsg(p, ("Managed pointer must not be null\n"));
[New Thread 28ca3c40 (LWP 100259)]
[New Thread 28ca4140 (LWP 100257)]
[New Thread 28ca4280 (LWP 100256)]
[New Thread 28c01140 (LWP 100153)]
(gdb) bt
#0 0x0805c5df in ComPtrBase<ISystemProperties>::operator-> (this=0xbfbfe654) at ptr.h:236
#1 0x080a48c2 in handleSetProperty (a=0xbfbfe784)
at /backup/ports/emulators/virtualbox-ose/work/VirtualBox-3.2.8_OSE/src/VBox/Frontends/VBoxManage/VBoxManageMisc.cpp:639
#2 0x0804c017 in main (argc=4, argv=0xbfbfe830)
at /backup/ports/emulators/virtualbox-ose/work/VirtualBox-3.2.8_OSE/src/VBox/Frontends/VBoxManage/VBoxManage.cpp:404
(gdb)

Attachments

VBox-logs.tar Download (18.0 KB) - added by Dorlas 4 years ago.

Change History

Changed 4 years ago by Dorlas

comment:1 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #7380.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use