VirtualBox

Ticket #7369 (closed defect: fixed)

Opened 4 years ago

Last modified 3 years ago

Occasionally get very small window size when restoring saved state

Reported by: nim Owned by:
Priority: major Component: GUI
Version: VirtualBox 3.2.10 Keywords:
Cc: Guest type: other
Host type: other

Description

I don't know how it comes (not always reproducible).

Sometimes when I restore a saved guest os, the window is too small at upper left corner of the screen, and the window title bar is not visible (above top of screen).

Attachments

vbox-bug.log Download (39.9 KB) - added by kuester2000 4 years ago.
After restoring the window is not visible. After clicking "show" a smatt window on the top left corner of screen is shown without content. The content si not refreshed when window is moved
window-problem.PNG Download (19.7 KB) - added by camason 4 years ago.
When restoring, the menu bar is white but still usable

Change History

comment:1 Changed 4 years ago by kuester2000

I am seeing the same behaviour. It is 100% reproducible with one debian guest system and not reproducible with another quite similar debian guest system. The samll window can be rezised. After resizing I see about two pixels of the title bar. So I can grab and move it. It does not show any content. If I click on the close symbol on the top right side, I can choose to exit.

Changed 4 years ago by kuester2000

After restoring the window is not visible. After clicking "show" a smatt window on the top left corner of screen is shown without content. The content si not refreshed when window is moved

comment:2 Changed 4 years ago by alex.lg

Clicking in the (empty) window at the top left corner - where the menu should be shown - it's possible to switch to "full screen mode" (the menu is hidden, but accessible). Then the content/ the guest screen is restored. After switching back from "full screen mode" everything seems to work again.

comment:3 Changed 4 years ago by nim

Update - 3.2.10 still has this bug.

comment:4 Changed 4 years ago by frank

  • Version changed from VirtualBox 3.2.8 to VirtualBox 3.2.10

Changed 4 years ago by camason

When restoring, the menu bar is white but still usable

comment:5 Changed 4 years ago by camason

This has happened to me on 2 separate Windows 7 x64 hosts, and happens very frequently with a single guest. This guest was migrated from one system to another (using backed up XML) and seems to reproduce the problem frequently on the new machine.

It doesn't always happen - probably 75% of the time. It will usually restore, but no window appears. I must right click -> show on the guest in the main Virtualbox window. It starts at a very small size and must be resized.

comment:6 Changed 3 years ago by nim

Still get this bug occasionally using version 3.2.12.

comment:7 Changed 3 years ago by nim

Did not have this bug since version 4. Seems fixed.

comment:8 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Thanks for the feedback!

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use