VirtualBox

Ticket #7334 (closed defect: fixed)

Opened 4 years ago

Last modified 4 years ago

/dev/vboxdrv and /dev/vboxnetctl going missing after reboot

Reported by: aztrix Owned by:
Priority: major Component: other
Version: VirtualBox 3.2.8 Keywords: vboxdrv vboxnetctl missing reboot
Cc: Guest type: Windows
Host type: Linux

Description

Howzit Folks?

Whenever I reboot my server I get the following error when starting VirtualBox:

VBoxManage startvm Win-VM --type gui

WARNING: The vboxdrv kernel module is not loaded. Either there is no module available for the current kernel (2.6.34-12-desktop) or it failed to load. Please recompile the kernel module and install it by sudo /etc/init.d/vboxdrv setup

You will not be able to start VMs until this problem is fixed. Oracle VM VirtualBox Command Line Management Interface Version 3.2.8 (C) 2005-2010 Oracle Corporation All rights reserved.

Waiting for the VM to power on ERROR: The virtual machine 'Win-VM' has terminated unexpectedly during startup with exit code 1 Details: code NS_ERROR_FAILURE (0x80004005), component Machine, interface IMachine, callee

which is caused by /dev/vboxdrv and /dev/vboxnetctl going missing after reboot. Running sudo /etc/init.d/vboxdrv setup reinstates the missing devices and I can run VirtualBox.

My pc configuration is as follows:

OS/Desktop: openSUSE 11.3 - Linux 2.6.34-12-desktop x86_64 KDE 4.4.4

CPU: AMD Phenom 9500 Quad Core Processor

Memory: 8GB DDR2 Ram

Motherboard: M2A-VM - AMD 690G Chipset

Graphics: 1GB ATI Radeon X1250 Graphics

Hard drive: Samsung 500GB SATA

Any questions, give me a shout.

Cheers Bruce

Attachments

vbox-install.log Download (104.9 KB) - added by aztrix 4 years ago.
vbox-install.log
VBox.log Download (81.6 KB) - added by aztrix 4 years ago.
VBox.log

Change History

Changed 4 years ago by aztrix

vbox-install.log

Changed 4 years ago by aztrix

VBox.log

comment:1 follow-up: ↓ 2 Changed 4 years ago by frank

Are these devices really gone after each reboot or only after you upgraded your Linux kernel?

comment:2 in reply to: ↑ 1 Changed 4 years ago by aztrix

Replying to frank:

Are these devices really gone after each reboot or only after you upgraded your Linux kernel?

It never used to be an issue but whenever I reboot they've definitely gone awol. I upgraded to openSUSE 11.3 recently but have subsequently upgraded to VirtualBox 3.2.8 but I don't remember when exactly the problem started as I don't reboot that often and assumed that the problem was related to a recent upgrade of VirtualBox.

comment:3 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to wontfix

Well, you installed VBox on a openSUSE host. That distribution does not provide the DKMS package. DKMS would ensure that the VirtualBox kernel modules are recompiled when you install a newer kernel. Therefore you have to execute /etc/init.d/vboxdrv setup manually each time you installed a new kernel. Sorry, but there is not much we can do about this. Other distributions (Ubuntu, Fedora, Mandriva) provide this package and allow that automatism.

comment:4 Changed 4 years ago by aztrix

  • Status changed from closed to reopened
  • Resolution wontfix deleted

Nothing to do with DKMS and automation, I have run /etc/init.d/vboxdrv setup manually and have to after every reboot even though I haven't upgraded or installed a new kernel.

comment:5 Changed 4 years ago by frank

Well, it works here on openSUSE 11.3 without any problems. So after a reboot you should check the following: Do

$ lsmod|grep vbox
vboxnetadp              5587  0
vboxnetflt             16481  0
vboxdrv              1806371  2 vboxnetadp,vboxnetflt

There should be three VirtualBox kernel modules loaded. If so, check the permissions of the vboxdrv device with

$ /bin/ls -l /dev/vbox*
crw------- 1 root vboxusers 10, 58 2010-08-19 08:19 /dev/vboxdrv
crw------- 1 root root      10, 57 2010-08-19 08:19 /dev/vboxnetctl

Furthermore check if the script /etc/init.d/vboxdrv is properly run during boot:

$ grep :initdefault /etc/inittab
id:5:initdefault
$ cd /etc/init.d/rc5.d
$ ls -l *vbox*
K01vboxdrv -> ../vboxdrv
S04vboxdrv -> ../vboxdrv

comment:6 Changed 4 years ago by aztrix

After reboot:

lsmod|grep vbox
<- No output ->
ls -l /dev/vbox*
ls: cannot access /dev/vbox*: No such file or directory
grep :initdefault /etc/inittab
id:5:initdefault:
cd /etc/init.d/rc5.d
ls -l *vbox*
ls: cannot access *vbox*: No such file or directory

After /etc/init.d/vboxdrv setup

Stopping VirtualBox kernel module              done
Removing old VirtualBox netadp kernel module   done
Removing old VirtualBox netflt kernel module   done
Removing old VirtualBox kernel module          done
Recompiling VirtualBox kernel module           done
Starting VirtualBox kernel module              done
lsmod|grep vbox
vboxnetadp              5587  0 
vboxnetflt             16513  0 
vboxdrv              1806371  2 vboxnetadp,vboxnetflt
ls -l /dev/vbox*
crw------- 1 root vboxusers 10, 58 Aug 19 19:25 /dev/vboxdrv
crw------- 1 root root      10, 57 Aug 19 19:25 /dev/vboxnetctl
grep :initdefault /etc/inittab
id:5:initdefault:
cd /etc/init.d/rc5.d
ls -l *vbox*
ls: cannot access *vbox*: No such file or directory

So it looks like K01vboxdrv & S04vboxdrv have gone AWOL, I'll try re-installing VirtualBox and see if it fixes it, failing that I will create these 2 symlinks.

I'll report back shortly.

comment:7 Changed 4 years ago by aztrix

I did a complete uninstall and re-install ... lo and behold K01vboxdrv & S04vboxdrv are there.

Thanks for your help Frank.

Cheers Bruce

comment:8 Changed 4 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

Thanks for the feedback!

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use