VirtualBox

Ticket #7330 (reopened defect)

Opened 4 years ago

Last modified 3 years ago

Unable to toggle guest screen size after pause via keyboard (linux/windows hosts)

Reported by: v0box Owned by:
Priority: major Component: other
Version: VirtualBox 3.2.8 Keywords:
Cc: Guest type: other
Host type: other

Description

In the 3.1.x series of vbox I could toggle the guest screen size from fullscreen/window and back when the guest session was paused. That is, the host keyboard sequence:

cntl-P (pause guest), then cntl-F (toggle guest fullscreen/window) would work.

In series 3.2.x this sequence does not work:

cntl-P (pause works), then cntl-F (nothing happens).

The sequence cntl-F (toggle full/window), then cntl-P (pause) does work, but I would like to see the 3.1.x behavior back.

This is happens for both x86 linux/windows hosts with both linux/windows guests.

Kind regards and thanks in advance.

Change History

comment:1 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to wontfix

Actually I don't think this does make much sense.

comment:2 Changed 3 years ago by v0box

  • Status changed from closed to reopened
  • Resolution wontfix deleted

I guess I was not clear.

I usually run my guests in full-screen mode, the layout of windows in those guests arranged in a particular manner, be they linux or windows guests on both linux and windows hosts.

In VB versions 3.1x and before, from full-screen mode I can pause the guest (ctl-P), then drop from full-screen mode (ctl-F), do what needs to be done on the host, then reverse the sequence (ctl-F, ctl-P) and be back in my guest with everything arranged as before.

In all versions of VB since 3.1.8 the only thing I can do is drop from full screen mode first, then pause the guest (ctl-F, ctl-P). The issue is that this distorts the arrangement of my guest windows (due to re-sizing the guest desktop) when returning to full-screen mode. Put another way, the sequence ctl-P, then ctl-F no longer works and the sequence that *does* work (ctl-F, ctl-P) distorts my nice guest window arrangement.

I realize this is probably not a big deal for most, but I'd like to see the old behavior also work on the newer versions of VB.

Thanks.

Mike Robbins

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use