VirtualBox

Ticket #7315 (closed defect: worksforme)

Opened 4 years ago

Last modified 4 years ago

upgrade in Debian Lenny can't be done due to VirtualBox version

Reported by: onorua Owned by:
Priority: major Component: installer
Version: VirtualBox 3.2.8 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

Here is the error I've got during GNU Debian Linux upgrade:

=========

dpkg: ошибка разбора, файл `/var/lib/dpkg/available' около строки 31625 пакета 'virtualbox-3.1':

ошибка в строке Version `3.1.2-56127_Debian_lenny': invalid character in revision number

E: Sub-process /usr/bin/dpkg returned an error code (2)

=========

It can be hotfixed by modyfing /var/lib/dpkg/available and /var/lib/dpkg/stat, just need to delete "_Debian_lenny" postfix in the lines dpkg stated.

Change History

comment:1 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to worksforme

VBox 3.1.2 != VBox 3.2.8 (version field of this ticket). The invalid version number was fixed in VBox 3.1.8, the latest release 3.2.8 has a fixed version number as well.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use